View Single Post
  #2  
Old 7th October 2005, 15:25
falko falko is offline
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 41,711
Thanks: 1,899
Thanked 2,702 Times in 2,545 Posts
Default

Quote:
Originally Posted by ctroyp
#1
I have one domain setup under my admin account. I have another domain under another account. I have ftp setup the same (to the best of my knowledge) on both accounts. Under the second domain I can access the ftp files fine, but under the first, I can access the ftp site, but it is in the wrong directory. The directory should point to: /home/www/web1/web/, correct. It actually points to: /home/"username"/.

I have looked in the ISPConfig files, including Vhosts and everything seems to point to /home/www/web1/web/. Why is the ftp site not being directed properly? Would it have anything to do with my LAN setup?
Make sure you're using the right ftp user for your first web site. To me it seems as if you had set up a usef manually on the shell with the homedir /home/user, and you're using this user for ftp.
You have to use a user that you set up with ISPConfig.

Quote:
Originally Posted by ctroyp
#2
The second issue may correlate to the first, so I am posting them together. I can access the ftp sites for either domain setup in ISP config from anywhere outside of my server. But when I open my browser on the server and type in the ftp url for either one, I get a "530 Login incorrect!" alert popup. It doesn't even allow me to enter a login. Does this mean that anon users are enabled? If so where else can I disable anon access? I though I did this already...
If anonymous ftp was enabled, then you wouldn't get the "Login incorrect" message.
Did you try this syntax in your browser?
ftp://<username>:<password>@<ftpserver>
__________________
Falko
--
Download the ISPConfig 3 Manual! | Check out the ISPConfig 3 Billing Module!

FB: http://www.facebook.com/howtoforge

nginx-Webhosting: Timme Hosting | Follow me on:
Reply With Quote