View Single Post
  #1  
Old 7th October 2005, 16:18
ProTrooper ProTrooper is offline
Member
 
Join Date: Aug 2005
Posts: 36
Thanks: 0
Thanked 0 Times in 0 Posts
Default ProFTPd on CentOS, many small problems

After many hours I finally got a server up and running with only Apache and ProFTPd. Because I am using CentOS I had to install ProFTPd "manually." Now I am testing and I am finding a few problems. Please note, this is not for installing ISPConfig.

First, after installing there was no startup script in /etc/init.d, I had to run it from /usr/local/sbin/proftpd. I tried copying a script from Fedora and I guess the libraries are different because I recieve this error: "Starting proftpd: execvp: No such file or directory"

Also, with the test user I created, PAM authentication fails. I added the file /etc/pam.d/proftpd but it did nothing.

When I log in as my test user (to web root which is 770), I created a folder and uploaded a test php page. The script uploaded fine but had permissions 544. I tried to change permissions and was denied.

Finally, I was able to browse my entire ftp server. I am not quite sure how that happened, but I want to lock users into specific directories.

Any help would be greatly appreciated.

Thanks,
James
Reply With Quote
Sponsored Links