View Single Post
  #8  
Old 8th August 2006, 22:53
AndyF AndyF is offline
Junior Member
 
Join Date: Aug 2006
Posts: 7
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well i'm not quite sure what i've done, but it is now working correctly.

i did renter a couple of postconf lines and instead of before where is wasn't even checking for the sasl_authenticated.

Code:
>>> START Recipient address RESTRICTIONS <<<
Aug  8 20:01:09 woody postfix/smtpd[27060]: generic_checks: name=permit_mynetworks
Aug  8 20:01:09 woody postfix/smtpd[27060]: permit_mynetworks: unknown 192.168.1.10
Aug  8 20:01:09 woody postfix/smtpd[27060]: match_hostname: unknown ~? 127.0.0.0/8
Aug  8 20:01:09 woody postfix/smtpd[27060]: match_hostaddr: 192.168.1.10 ~? 127.0.0.0/8
Aug  8 20:01:09 woody postfix/smtpd[27060]: match_list_match: unknown: no match
Aug  8 20:01:09 woody postfix/smtpd[27060]: match_list_match: 192.168.1.10: no match
Aug  8 20:01:09 woody postfix/smtpd[27060]: generic_checks: name=permit_mynetworks status=0
Aug  8 20:01:09 woody postfix/smtpd[27060]: generic_checks: name=reject_unauth_destination
i then redid the line

Code:
postconf -e 'smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject_unauth_destination'
Restarted the service and finally received..

Code:
>>> START Recipient address RESTRICTIONS <<<
Aug  8 20:20:30 woody postfix/smtpd[28068]: generic_checks: name=permit_sasl_authenticated
Aug  8 20:20:30 woody postfix/smtpd[28068]: generic_checks: name=permit_sasl_authenticated status=0
Aug  8 20:20:30 woody postfix/smtpd[28068]: generic_checks: name=permit_mynetworks
Aug  8 20:20:30 woody postfix/smtpd[28068]: permit_mynetworks: unknown 192.168.1.10
Aug  8 20:20:30 woody postfix/smtpd[28068]: match_hostname: unknown ~? 127.0.0.0/8
Aug  8 20:20:30 woody postfix/smtpd[28068]: match_hostaddr: 192.168.1.10 ~? 127.0.0.0/8
Aug  8 20:20:30 woody postfix/smtpd[28068]: match_list_match: unknown: no match
Aug  8 20:20:30 woody postfix/smtpd[28068]: match_list_match: 192.168.1.10: no match
Aug  8 20:20:30 woody postfix/smtpd[28068]: generic_checks: name=permit_mynetworks status=0
Aug  8 20:20:30 woody postfix/smtpd[28068]: generic_checks: name=reject_unauth_destination
Which looks miles better, so i now get.

Code:
Aug  8 20:36:38 woody postfix/smtpd[28346]: connect from 82-68-241-110.dsl.in-addr.zen.co.uk[82.68.241.110]
Aug  8 20:36:38 woody postfix/smtpd[28346]: D624C81838D: client=82-68-241-110.dsl.in-addr.zen.co.uk[82.68.241.110], sasl_method=LOGIN, sasl_username=andy
Aug  8 20:36:38 woody postfix/cleanup[28348]: D624C81838D: message-id=<20060808193638.D624C81838D@woody.friar.info>
Aug  8 20:36:38 woody postfix/qmgr[27948]: D624C81838D: from=<andy@friar.info>, size=2210, nrcpt=1 (queue active)
Aug  8 20:36:39 woody postfix/smtp[28349]: D624C81838D: to=<andy@novus.co.uk>, relay=mail.novus.co.uk[212.248.238.50], delay=1, status=sent (250 imss-01.NNL.CO.UK: Message accepted for delivery)
Aug  8 20:36:39 woody postfix/qmgr[27948]: D624C81838D: removed
By the way for more debuging options add the following into your main.cf

debug_peer_list = IPADDRESSYOURWANTTODEBUG
debug_peer_level = 3

Hope this helps anyone else.

Andy
Reply With Quote