View Single Post
  #1  
Old 7th August 2006, 12:33
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,266
Thanks: 82
Thanked 24 Times in 20 Posts
Default permissions problem on the /var/www/webXX folders

hi there,

I just commited a big mistake: I was trying to get a plugin for a thirdparty app running which needed certain permissions on the /var/www/web1 folder.

what I did without thinking was this: chown -R web1_postmaster:www-data /var/www/web1 and chmod -R 755 /var/www/web1

now I realized that my permissions are totally borked, my 2 users inside this site cannot read their emails etc.

how can I undo this mess as fast as possible?

p.s. I have a backup from this morning done with ftplicity, so I tried ftplicity fetch var/www/web1 /var/www 1D but it just tells me it cannot overwrite. I tried fetch var/www/web1 /var/www/bckp 1D and then copied all folders and files over with the result, that the main user can login and read mails while the other user cannot even login, he gets this error: ERROR: Connection dropped by IMAP server

any clues, please

###edit###
basically I chowned user:group the user directories (including the subdirectories) and mail is working now.
anything else that could need fixing?

Last edited by Ovidiu; 7th August 2006 at 12:43.
Reply With Quote
Sponsored Links