View Single Post
  #1  
Old 3rd August 2006, 21:28
GrBase GrBase is offline
Junior Member
 
Join Date: Aug 2006
Posts: 14
Thanks: 0
Thanked 0 Times in 0 Posts
Default Postfix + Fedora Core 5 64Bit - Problem

I have install Fedora core 5 following the instructions of "The Perfect Setup - Fedora Core 5 (64-bit)" by Falko
I am running a 64bit AMD Athlon which I want to make it a web and mail server.
The web server is working ok!! but the mail server is not working properly.
When I am trying to send and receive e-mail from a WINxp system using outlook and an account on the Fedora server, it seems to working ok but no e-mails are sent or received. Outlook is connected to the server and finds no new messages. When I am trying to send an e-mail outlook says that the message is sent but the message doesn’t go to the recipient.
I am using Postfix and when I am trying telnet local host 25 I am getting ............
--------------------------------------------------
[root@ns ~]# telnet localhost 25
Trying 127.0.0.1...
Connected to localhost.localdomain (127.0.0.1).
Escape character is '^]'.
220 ns.nestor.org.gr ESMTP Postfix
ehlo localhost
250-ns.nestor.org.gr
250-PIPELINING
250-SIZE 10240000
250-VRFY
250-ETRN
250-STARTTLS
250-AUTH LOGIN PLAIN
250-AUTH=LOGIN PLAIN
250 8BITMIME
quit
221 Bye
Connection closed by foreign host.
[root@ns ~]#
--------------------------------------------------

I notice that at /home/<anyuser>/Maildir don't exist, there is only 'mail' folder

The /etc/postfix/main.cf file is as following
---------------------------------------------------------------------
queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
myhostname = ns.nestor.org.gr
mydomain = nestor.org.gr
inet_interfaces = all
mydestination = $myhostname, localhost.$mydomain, localhost
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
alias_database = hash:/etc/aliases
debug_peer_level = 2
debugger_command = PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin xxgdb $daemon_directory/$process_name $process_id & sleep 5
home_mailbox = Maildir/
mailbox_command =
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.2.8/samples
readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
-------------------------------------------------------------------------

It seems I am doing something wrong
Reply With Quote
Sponsored Links