View Single Post
  #1  
Old 2nd August 2006, 20:27
Sarcha Sarcha is offline
Junior Member
 
Join Date: Aug 2006
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default Outgoing email problems

I have just recently setup a new server following the Prefect Setup guide for Fedora Core 5. I then installed ISPConfig per the intructions provided. I am able to recieve mail from outside and send mail internally. I just cannot send out to any other domains. When I try to send out I get an email back with
The following recipient(s) cannot be reached:
'service@advcomputers.com' on 8/2/2006 12:34 PM
550 <service@advcomputers.com>: Recipient address rejected: User unknown in local recipient table

Some of the other email I send to hotmail addresses never arrives and no messages come back.

My mail log file looks like this...

Aug 2 12:32:44 ns1 postfix/qmgr[12302]: 1A0DD834415: from=<scott@advcomputers.ca>, size=2688, nrcpt=1 (queue active)
Aug 2 12:32:45 ns1 postfix/master[12299]: warning: process /usr/libexec/postfix/smtp pid 12304 exit status 1
Aug 2 12:32:45 ns1 postfix/master[12299]: warning: /usr/libexec/postfix/smtp: bad command startup -- throttling
Aug 2 12:33:32 ns1 postfix/smtpd[12323]: warning: connect to private/tlsmgr: Connection refused
Aug 2 12:33:32 ns1 postfix/smtpd[12323]: warning: problem talking to server private/tlsmgr: Connection refused
Aug 2 12:33:33 ns1 postfix/smtpd[12323]: warning: connect to private/tlsmgr: Connection refused
Aug 2 12:33:33 ns1 postfix/smtpd[12323]: warning: problem talking to server private/tlsmgr: Connection refused
Aug 2 12:33:33 ns1 postfix/smtpd[12323]: warning: no entropy for TLS key generation: disabling TLS support
Aug 2 12:33:33 ns1 postfix/smtpd[12323]: connect from unknown[10.10.10.5]
Aug 2 12:33:33 ns1 postfix/smtpd[12323]: AEA7A834417: client=unknown[10.10.10.5], sasl_method=PLAIN, sasl_username=web1_scott
Aug 2 12:33:33 ns1 postfix/smtpd[12323]: AEA7A834417: reject: RCPT from unknown[10.10.10.5]: 550 <service@advcomputers.com>: Recipient address rejected: User unknown in local recipient table; from=<scott@advcomputers.ca> to=<service@advcomputers.com> proto=ESMTP helo=<TECHSHOP>
Aug 2 12:33:33 ns1 postfix/cleanup[12325]: AEA7A834417: message-id=<000801c6b651$64ebf7b0$2ec3e710$@ca>
Aug 2 12:33:33 ns1 postfix/qmgr[12302]: AEA7A834417: from=<scott@advcomputers.ca>, size=2718, nrcpt=1 (queue active)
Aug 2 12:33:38 ns1 postfix/smtpd[12323]: disconnect from unknown[10.10.10.5]
Aug 2 12:33:45 ns1 postfix/smtp[12331]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Aug 2 12:33:46 ns1 postfix/master[12299]: warning: process /usr/libexec/postfix/smtp pid 12331 exit status 1
Aug 2 12:33:46 ns1 postfix/master[12299]: warning: /usr/libexec/postfix/smtp: bad command startup -- throttling
Aug 2 12:34:46 ns1 postfix/smtp[12352]: fatal: specify a password table via the `smtp_sasl_password_maps' configuration parameter
Aug 2 12:34:47 ns1 postfix/master[12299]: warning: process /usr/libexec/postfix/smtp pid 12352 exit status 1
Aug 2 12:34:47 ns1 postfix/master[12299]: warning: /usr/libexec/postfix/smtp: bad command startup -- throttling
Aug 2 12:35:12 ns1 dovecot: pop3-login: Login: user=<web1_scott>, method=PLAIN, rip=::ffff:10.10.10.5, lip=::ffff:10.10.10.1
Aug 2 12:35:12 ns1 dovecot: POP3(web1_scott): Disconnected: Logged out top=0/0, retr=0/0, del=0/0, size=0

My main.cf file looks like this...

queue_directory = /var/spool/postfix
command_directory = /usr/sbin
daemon_directory = /usr/libexec/postfix
mail_owner = postfix
inet_interfaces = all
unknown_local_recipient_reject_code = 550
alias_maps = hash:/etc/aliases
debug_peer_level = 2
debugger_command =
PATH=/bin:/usr/bin:/usr/local/bin:/usr/X11R6/bin
xxgdb $daemon_directory/$process_name $process_id & sleep 5
sendmail_path = /usr/sbin/sendmail.postfix
newaliases_path = /usr/bin/newaliases.postfix
mailq_path = /usr/bin/mailq.postfix
setgid_group = postdrop
html_directory = no
manpage_directory = /usr/share/man
sample_directory = /usr/share/doc/postfix-2.2.8/samples
readme_directory = /usr/share/doc/postfix-2.2.8/README_FILES
smtp_sasl_local_domain =
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
broken_sasl_auth_clients = yes
smtpd_recipient_restrictions = permit_sasl_authenticated,permit_mynetworks,reject _unauth_destination
smtpd_tls_auth_only = no
smtp_use_tls = yes
smtpd_use_tls = yes
smtp_tls_note_starttls_offer = yes
smtpd_tls_key_file = /etc/postfix/ssl/smtpd.key
smtpd_tls_cert_file = /etc/postfix/ssl/smtpd.crt
smtpd_tls_CAfile = /etc/postfix/ssl/cacert.pem
smtpd_tls_loglevel = 1
smtpd_tls_received_header = yes
smtpd_tls_session_cache_timeout = 3600s
tls_random_source = dev:/dev/urandom
smtpd_sasl_local_domain =
smtpd_sasl_auth_enable = yes
smtpd_sasl_security_options = noanonymous
virtual_maps = hash:/etc/postfix/virtusertable
mydestination = /etc/postfix/local-host-names

Any help with this problem would be great! I'm just not sure what I'm missing.

Thanks,
Scott
Reply With Quote
Sponsored Links