View Single Post
  #7  
Old 28th September 2005, 23:15
uralter_artifex uralter_artifex is offline
Junior Member
 
Join Date: Sep 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Thanks for the quick reply.
The ispconfig.log shows no errors. The apache log has the line
Code:
[Wed Sep 28 12:59:18 2005] [error] an unknown filter was not added: PHP
in it, but .php files work as long as they are in /home/www/web1/web and not in a subdirectory below that.

The Vhosts_ispconfig.conf looks like this:
Code:
###################################
#
# ISPConfig vHost Configuration File
#         Version 1.0
#
###################################
#
NameVirtualHost 85.214.25.27:80
#
#
######################################
# Vhost: www.luxev-ratingen.de:80
######################################
#
#
<VirtualHost 85.214.25.27:80>
ServerName www.luxev-ratingen.de:80
ServerAdmin webmaster@luxev-ratingen.de
DocumentRoot /home/www/web1/web
ServerAlias luxev-ratingen.de
DirectoryIndex index.html index.php index.php5 index.php4 index.php3 index.shtml index.cgi index.pl index.jsp Default.htm default.htm
ErrorLog /home/www/web1/log/error.log
AddType application/x-httpd-php .php .php3 .php4 .php5
<Files *.php>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php3>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php4>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
<Files *.php5>
    SetOutputFilter PHP
    SetInputFilter PHP
</Files>
php_admin_flag safe_mode Off
Alias /error/ "/home/www/web1/web/error/"
ErrorDocument 400 /error/invalidSyntax.html
ErrorDocument 401 /error/authorizationRequired.html
ErrorDocument 403 /error/forbidden.html
ErrorDocument 404 /error/fileNotFound.html
ErrorDocument 405 /error/methodNotAllowed.html
ErrorDocument 500 /error/internalServerError.html
ErrorDocument 503 /error/overloaded.html
AliasMatch ^/~([^/]+)(/(.*))? /home/www/web1/user/$1/web/$3
AliasMatch ^/users/([^/]+)(/(.*))? /home/www/web1/user/$1/web/$3
</VirtualHost>
When I try to access the directory /home/www/web1/web/quickstart-3.8.0 which is part of typo3, Apache shows
Code:
Forbidden

You don't have permission to access /quickstart-3.8.0/typo3/install/index.php on this server.

Additionally, a 403 Forbidden error was encountered while trying to use an ErrorDocument to handle the request.
Apache/2.0.53 (Linux/SUSE) Server at www.luxev-ratingen.de Port 80
Permissions for these directories and files are still set to the site's admin (web1_adm.web).
I created the subdirectoy /home/www/web1/web/test and copied the original index.html into it. That works perfectly. Does the number of subdirectories make a difference? Or the softlink in the typo3 files?
There are no problems with typo3 on SuSE 9.3/Apache2 virtual hosts without ISPConfig.

Last edited by uralter_artifex; 28th September 2005 at 23:38.
Reply With Quote