View Single Post
  #6  
Old 27th September 2005, 21:57
fdawy fdawy is offline
Junior Member
 
Join Date: Sep 2005
Posts: 4
Thanks: 0
Thanked 0 Times in 0 Posts
Red face the Internet connection sharing problem the set

the Internet connection sharing problem the set


"""" Let's get started then:

Edit /etc/sysconfig/network-scripts/ifcfg-eth0 - This is the main config file for the first (internet facing) interface.
It should read : (you can leave out anything on a line after #)

DEVICE=eth0
BOOTPROTO=static
IPADDR=192.168.1.2
NETMASK=255.255.255.0
NETWORK=192.168.1.0
BROADCAST=192.168.1.255
ONBOOT=yes
MII_NOT_SUPPORTED=yes

Edit /etc/sysconfig/network-scripts/ifcfg-eth1 - This is the main config file for the second (LAN facing) interface.
It should read :

DEVICE=eth1
BOOTPROTO=static
IPADDR=192.168.3.1
NETMASK=255.255.255.0
NETWORK=192.168.3.0
BROADCAST=192.168.3.255
ONBOOT=yes
MII_NOT_SUPPORTED=yes
/etc/resolv.conf should contain the nameserver address(es) - put the address of your ISPs nameserver right at the top. eg:

nameserver 195.20.224.165You can have multiple nameserver xxx.xxx.xxx.xxx lines - the resolver will try them all in turn if one fails

The default gateway and your hostname go in /etc/sysconfig/network:

HOSTNAME=localhost
NETWORKING=yes
GATEWAY=192.168.1.1


We then need to set up packet forwarding:
Put the following command at the beginning of /etc/sysctl.conf

net.ipv4.ip_forward=1

Then 'turn off' the redirection to squid:
Install iptables - type "urpmi iptables" as root, or use the package manager in the start menu or mcc

Add the following code to the bottom of /etc/rc.d/rc.local.

iptables -t nat -D PREROUTING -i eth0 -j loc_dnatThis will delete a rule from your firewall - later, when you understand more, you can change shorewall and remove this line, but for now we'll keep it simple.


Reboot."""""""""


why problem
Reply With Quote