View Single Post
  #6  
Old 17th July 2006, 16:32
MetraDynamix MetraDynamix is offline
Junior Member
 
Join Date: Jul 2006
Posts: 16
Thanks: 0
Thanked 0 Times in 0 Posts
Default Please Help!

Quote:
Originally Posted by fobicodam
The problem here is that you are looking for errors on wrong places. Your problem is on your client side, thats why it doesnt work on any host. Did you try lowering your security settings? If you go to another site with flash can you see it? can you call directly the .swf file?

Its not a server problem. (unless some right doesnt allow the webserver read the file..)

I am new to Ubuntu and and some things such as ISPConfig, but I am very experienced with other things. I have been trying to explain that I know that it is not a client-side issue. Yes, other Flash Sites work. I tried from different computers, thus the odds of all of these computers and their browsers beeing flash-not-happy is 0. There has to be something in the way the server is configured that is blocking the flash-content. I am not sure how Apache interprets this content. Perhaps a permission issue yes. That is the reason why I am so confused, to me this problem is not very logical. I looked into the apache logs, the ones that I could find... I cannot locate anything in the error logs... I do not want to give up on this issue as I really want to start utilizing Linux and learning it... Anyone has any ideas of where I should be looking. It is not a Client Side issue.

I will admit that perhaps I am not configuring something right in ISPConfig or doing something wrong... Here is some more information....

I tried with Suexec and without. Compiled and configured ISPConfig once with and the other time without it. Meaning that once I tried serving from /home/www and now from /var/www

I checked CGI Scripts, PHP Scripts, FTP Access, MySQL for my site in the ISPConfig. Invidiual error pages, and Maildir. I also tried with various other combinations...

I am completely ignorant when it comes to DNS.. I did attempt to learn as much as I could but I am a bit confused on how it works.. I have a domain...
When I configured Ubuntu with the How-to, I utilized web01 instead of server1 and placed my domain. Thus web01.mydomain.com

Hostname and Hostname -f command does show web01.mydomain.com
ISPConfig does show under ISPConfig Settings -> DNS
Ns1: web01.mydomain.com
Ns2: web01.mydomain.com

I did go to my registrar which is internic.ca and replaced their two DNS servers that they had with my internet IP Address. Which I was a bit confused considering the fact that it wants two DNS Servers Primary and Secondary. I deleted their two name servers, and place in IP for Primary and Secondary my IP Address. From what I understand this should work, but not give me redundancy, which I do not care for at the moment...

My router is port forwarding DNS TCP/UDP, Web-80, FTP-21, Mail Pop-3 all to the server in question which has Ubuntu and ISPConfig...

I am using the internal IP address of 192.168.2.8; This is where I think that I may have went wrong.. but under ISPConfig, I have the following settings for Server.

Hostname: web01
Domain: mydomain.com
IP Address: 192.168.2.8
Netmask: 255.255.255.0
IP List: I added my internet IP in that list.

I know that it is a lot to ask at once.. I just wish to make this work and I am very lost at the moment. DNS is my biggest challenge it seems that I cannot just grasp exactly how to configure it perfectly, I am not sure if it could be playing a part in the problem...

If I could just understand the DNS portion, I think that things could be much better for me. Then in terms of the Flash problem, I am convinced that it is something with the way that DNS is addressing things and not downloading files properly OR that it has to do with something in the Apache permissions.

I created a user under ISPConfig; as it is the only method that I found that will give you FTP access. I use dreamweaver, FTP on my LAN to 192.168.2.8
I downloaded the entire content of the site; opened index.html which was under /web ... added some flash, uploaded it.

Any help is much appreciated!

Last edited by MetraDynamix; 17th July 2006 at 16:35.
Reply With Quote