View Single Post
  #1  
Old 7th July 2006, 05:44
snowfly snowfly is offline
Member
 
Join Date: Jul 2006
Posts: 93
Thanks: 0
Thanked 7 Times in 5 Posts
Default Problem with 'CC' & 'BCC' email not being delivered.

Hi,

I've got a problem with my mail server in that any 'CC' or 'BCC' email is not being delivered.

The sever is running virtual mail setup with:
- Debian Sarge
- 2.4.27 smp kernel
- courier 0.47-4 courier-pop, courier-imap, courier-authmysql
- postfix 2.1.5-0 postfix-mysql, postfix-tls
- maildrop 1.6.3, maildropmysql
- spamassassin
- clamav 0.88.2
- amavisd

Basically, if someone sends an email (from anywhere) to an email address on my server, and also CC or BCC an email address on my server, it gets delivered to the person in "To:", but not to "CC" and "BCC.

Eg: Consider the following 3 people
- PersonA with an external address: persona@gmail.com
- PersonB with address on my server: a@myserver.co.nz
- PersonC with address on my server: b@myserver.co.nz

Suppose PersonA sends the following email:
To: a@myserver.co.nz
CC: b@myserver.co.nz
Subject: foobar
Message: test

a@myserver.co.nz receives the email successfully in their inbox.
However b@myserver.co.nz doesn't, nothing arrives, seems the CC email disapears.

I get the following extract in my mail log:
Code:
Jul  7 14:12:10 aqua postfix/qmgr[31036]: 44C6554EAA: from=<persona@gmail.com>, size=3280, nrcpt=2 (queue active)
Jul  7 14:12:10 aqua amavis[8578]: (08578-04) ESMTP::10024 /var/amavis/tmp/amavis-20060707T140450-08578: <persona@gmail.com> -> <a@myserver.co.nz>,<b@myserver.co.nz> Received: SIZE=3280 from aqua.xxx.co.nz ([127.0.0.1]) by localhost (aqua [127.0.0.1]) (amavisd-n
ew, port 10024) with ESMTP id 08578-04; Fri,  7 Jul 2006 14:12:10 +1200 (NZST)
Jul  7 14:12:10 aqua amavis[8578]: (08578-04) Checking: <persona@gmail.com> -> <a@myserver.co.nz>,<b@myserver.co.nz>
Jul  7 14:12:11 aqua amavis[8578]: (08578-04) spam_scan: hits=0.087 tests=HTML_40_50,HTML_MESSAGE
Jul  7 14:12:11 aqua amavis[8578]: (08578-04) FWD via SMTP: [127.0.0.1]:10025 <persona@gmail.com> -> <a@myserver.co.nz>,<b@myserver.co.nz>
Jul  7 14:12:11 aqua amavis[8578]: (08578-04) Passed, <persona@gmail.com> -> <a@mysever.co.nz>,<b@myserver.co.nz>, Message-ID: <0
01f01c6a16a$c5c1de20$4503a8c0@Mike>, Hits: 0.087
Jul  7 14:12:11 aqua postfix/smtp[8931]: 44C6554EAA: to=<a@myserver.co.nz>, relay=127.0.0.1[127.0.0.1], delay=1, status=sent (250 2.6.
0 Ok, id=08578-04, from MTA: 250 Ok: queued as 17E4454EB6)
Jul  7 14:12:11 aqua postfix/smtp[8931]: 44C6554EAA: to=<b@myserver.co.nz>, relay=127.0.0.1[127.0.0.1], delay=1, status=sent (250 2.6
.0 Ok, id=08578-04, from MTA: 250 Ok: queued as 17E4454EB6)
Jul  7 14:12:11 aqua postfix/qmgr[31036]: 44C6554EAA: removed
Jul  7 14:12:11 aqua postfix/pipe[8936]: 17E4454EB6: to=<a@myserver.co.nz>, relay=virtual, delay=0, status=sent (xxxxx.co.nz)
Jul  7 14:12:11 aqua postfix/pipe[8936]: 17E4454EB6: to=<b@myserver.co.nz>, relay=virtual, delay=0, status=sent (xxxxx.co.nz)
Jul  7 14:12:11 aqua postfix/qmgr[31036]: 17E4454EB6: removed

Its the same with CC and BCC emails, and the same if the sender address is from an external address, or an internal address on my server.

Anyone experienced this, or something similar where CC/BCC emails don't get delivered?

One thing to note, is that if an email like the following is sent (internal user sends to external user, and CC's to internal user), then it works fine:
From: a@myserver.co.nz
To: persona@gmail.com
CC: b@myserver.co.nz
Subject: foobar
...

Last edited by snowfly; 23rd October 2008 at 18:02.
Reply With Quote
Sponsored Links