View Single Post
  #8  
Old 28th June 2006, 00:26
tom tom is offline
Senior Member
 
Join Date: Apr 2006
Posts: 492
Thanks: 8
Thanked 8 Times in 7 Posts
Default

Quote:
Originally Posted by tosser
The FastCGIServer is php-fcgi.
you define it dynamic for all vhosts. with execute php-fcgi in the php-starter-script and not with a static parameter in the fastcgi.conf!
ok, thanks! The diffenrent is between static and dynamic, aha:-)
So I had defined a static FastCGIServer and a dynamic one?

I created the fastcgi.conf like:
Code:
<IfModule mod_fastcgi.c>
 FastCgiIpcDir /var/lib/apache2/fastcgi
  AddHandler fastcgi-script .fcgi

  FastCgiWrapper /usr/lib/apache2/suexec2
  FastCgiServer /var/www/php-fcgi-scripts/web1/php-fcgi-starter -user web1_admin -group web1
 FastCgiServer /var/www/php-fcgi-scripts/web2/php-fcgi-starter -user web2_admin -group web2

   AddHandler php-fastcgi .php

<Location /cgi-bin/php-fcgi-starter>
        SetHandler fastcgi-script
        Options +ExecCGI
</Location>

Action php-fastcgi /cgi-bin/php-fcgi-starter

AddType application/x-httpd-php .php
</IfModule>
and the starter script like:
Code:
#!/bin/sh
PHPRC="/var/www/php-fcgi-scripts/web1"
export PHPRC
PHP_FCGI_CHILDREN=4
export PHP_FCGI_CHILDREN
exec /var/www/php-fcgi-scripts/php5-fcgi-hard/bin/php
and for the vhosts (include in isp httpd.conf options field):
Code:
ScriptAlias /cgi-bin/ /var/www/php-fcgi-scripts/web1/
<Directory '/var/www/php-fcgi-scripts/web1'>
AllowOverride None
Options +ExecCGI -MultiViews -Indexes
Order allow,deny
Allow from all
</Directory>
You mean this
Code:
  FastCgiServer /var/www/php-fcgi-scripts/web1/php-fcgi-starter -user web1_admin -group web1
 FastCgiServer /var/www/php-fcgi-scripts/web2/php-fcgi-starter -user web2_admin -group web2
I have to take off because it's I've already defined the FastCgiServer dynamicly by
PHPRC="/var/www/php-fcgi-scripts/web1", right?

Last edited by tom; 28th June 2006 at 00:30.
Reply With Quote