View Single Post
  #1  
Old 3rd July 2013, 12:08
abubin abubin is offline
Member
 
Join Date: Mar 2010
Posts: 81
Thanks: 0
Thanked 2 Times in 2 Posts
Default problem implementing wildcard SSL

i am having problem getting wildcard SSL to work in ispconfig.

I have followed some guide in this forum on implementing pre-configured SSL but it still doesn't work.

Getting error
Code:
Secure Connection Failed

          An error occurred during a connection to domain.com.

SSL received a record that exceeded the maximum permissible length.

(Error code: ssl_error_rx_record_too_long)
I even tried to manually configure the SSL but it doesn't work.

I am using ubuntu 10.04LTS.

I have ispconfig gui running in self-created SSL cert. Could this be the reason for the problem? Perhaps I should disable SSL in ispconfig gui and then try to configure the website again to use SSL?

Would really appreciate help from the pros here.

more errors from apache logs:
Quote:
[Wed Jul 03 15:58:03 2013] [error] SSL Library Error: 185073780 error:0B080074:x509 certificate routines:X509_check_private_key:key values mismatch
Quote:
[Wed Jul 03 15:58:03 2013] [warn] RSA server certificate wildcard CommonName (CN) `*.domain.com' does NOT match server name!?
thanks.

Last edited by abubin; 3rd July 2013 at 12:11.
Reply With Quote
Sponsored Links