Thread: DNS problem
View Single Post
  #1  
Old 29th June 2013, 01:56
ababneh ababneh is offline
Junior Member
 
Join Date: Mar 2013
Posts: 28
Thanks: 0
Thanked 1 Time in 1 Post
Smile DNS problem

I have a VPS freshly set up using: The Perfect Server - Ubuntu 12.04 LTS (nginx, BIND, Dovecot, ISPConfig 3)

So far I am still trying to figure out how to get rid of the error:

root@server:/etc/bind# ls
Code:
bind.keys  db.empty    named.conf.default-zones     rndc.key
db.0       db.local    named.conf.local             slave
db.127     db.root     named.conf.options           zones.rfc1918
db.255     named.conf  pri.ns1.example.com.err
the contents of the error file:

Code:
$TTL        3600
@       IN      SOA     ns1.example.com. mail.example.com. (
                        2013062812       ; serial, todays date + todays serial #
                        7200              ; refresh, seconds
                        540              ; retry, seconds
                        604800              ; expire, seconds
                        86400 )            ; minimum, seconds
;

example.com. 3600 A        173.333.222.105
example.com. 3600      MX    10   mail.example.com.
example.com. 3600      NS        ns1.example.com.
example.com. 3600      NS        ns2.example.com.
mail 3600 A        173.333.222.105
ns1 86400 A        173.333.222.105
ns2 86400 A        173.333.222.105
www 3600 A        173.333.222.105
I also tried this

Code:
root@server:/# dig @localhost example.com

; <<>> DiG 9.8.1-P1 <<>> @localhost example.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 54614
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;example.               IN      A

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Fri Jun 28 22:41:11 2013
;; MSG SIZE  rcvd: 33
And

Code:
root@server:/# dig @localhost ns1.example.com

; <<>> DiG 9.8.1-P1 <<>> @localhost ns1.example.com
; (1 server found)
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: SERVFAIL, id: 22830
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 0

;; QUESTION SECTION:
;ns1.example.com.           IN      A

;; Query time: 0 msec
;; SERVER: 127.0.0.1#53(127.0.0.1)
;; WHEN: Fri Jun 28 22:44:56 2013
;; MSG SIZE  rcvd: 37
I checked /var/log/syslog and it is empty.

I can access the site via the ip address but when I point the browser to example.com I get "server not found" (on Firefox) and "This webpage is not available" (on chrome).


Any help with resolving this issue is appreciated.
Reply With Quote
Sponsored Links