View Single Post
  #13  
Old 21st June 2013, 19:40
zenny zenny is offline
Senior Member
 
Join Date: Nov 2006
Posts: 176
Thanks: 20
Thanked 6 Times in 6 Posts
Arrow

Quote:
Originally Posted by till View Post
SNI is compiled into the webserver, it does not require any additional configuration so it works by default.



Works fine here on all servers. Just perfect server setup with no additional configuration.
Only varnish is setup in front of apache listening to port 80 which I guess have nothing to do with the port 443 to which apache listens to for ssl.



Quote:
You enabled the default ssl vhost which will cause the webserver to redirect requests to a directory that should not be accessed and the correct reply is a forbiden error. The default-ssl vhost should not be enabled if you want to use sni for websites in ispconfig, thats why the perfect setup does not instruct you to enable it.
I discovered that and disabled the default-ssl, but in that case the server is back to square one as OP.

Quote:
If you wnat to use ssl in a website and get the website when you enter https in fron of the domain, then you have to enable ssl for that website in ispconfig and create a ssl cert for it in ispconfig.
Done exactly, but no go. And here I am to seek your help. On normal apache2 setup, it works fine, but not with ISPconfig3, that is where I am stuck.

Have a nice Midsummer!
Reply With Quote