View Single Post
  #1  
Old 3rd June 2013, 18:31
cyprus cyprus is offline
Member
 
Join Date: Oct 2011
Posts: 38
Thanks: 0
Thanked 0 Times in 0 Posts
Default Nginx doesnīt start without any output

I run a LEMP System on a Hetzner Server with Debian Squeeze and after some challenges, it worked without many problems.
But yesterday I ran into a problem.
I ran an upgrade of some progs and after the upgrade the apache and nginx seems to bee off. So I turned Apache off and tried to start nginx.
without any output:
This is my test:
Quote:
root@squeeze:~# fuser -n tcp 80
root@squeeze:~# /etc/init.d/nginx
root@squeeze:~# /etc/init.d/nginx stop
root@squeeze:~# /etc/init.d/nginx start
root@squeeze:~# ps auxw | grep nginx
root 23148 0.0 0.0 7548 860 pts/0 S+ 17:34 0:00 grep nginx
root@squeeze:~# killall nginx
nginx: no process found
root@squeeze:~# killall -9 nginx
nginx: no process found
I checked the log files but couldnīt find any significant.
Tried this:
Quote:
root@squeeze:~# sh -x /etc/init.d/nginx start
+ PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin
+ DAEMON=/usr/sbin/nginx
+ NAME=nginx
+ DESC=nginx
+ [ -f /etc/default/nginx ]
+ . /etc/default/nginx
+ test -x /usr/sbin/nginx
+ exit 0
Now I ran out of ideas and searching the web didnīt help me.
Thanx in advance for any hint
Cyprus
Reply With Quote
Sponsored Links