View Single Post
  #3  
Old 31st May 2013, 15:03
aljachimiak aljachimiak is offline
Junior Member
 
Join Date: May 2013
Posts: 3
Thanks: 0
Thanked 0 Times in 0 Posts
Default Thanks!

Thanks for the quick reply (and cleaning up the spam...)

It seems that my iptables rule for port 443 was gone.

Here is how I solved my problem:

(1) Open the port manually with iptables:
I ssh'd into the server and typed this:
Code:
sudo iptables -A INPUT -p tcp --dport 443 -j ACCEPT
(2) Tested for functionality:
Opened up my browser to https://<ipaddress>:8080 and saw the ispconfig3 login page.



(3) Make the rule permenent:
The easiest way I found to do this was to add it to the rc.local script. This script runs at the end of every boot process as root, so commands entered into this script will be executed every time the server boots.

I navigated to /etc
Code:
cd /etc
Then opened rc.local with nano
Code:
sudo nano rc.local
It was empty at the time, so I included the iptables rule just before exit on the script
Code:
iptables -A INPUT -p tcp --dport 443 -j ACCEPT
note: sudo is not necessary here because the script is executed as root.

Then I rebooted the server to test that it worked.

Success!

I'm sure there are several other ways to accomplish this. But it did restore the functionality that I needed.

If there is a better way to open that port, I'm open to suggestion.

Thanks!

Last edited by aljachimiak; 31st May 2013 at 15:05.
Reply With Quote