View Single Post
  #3  
Old 31st May 2013, 00:11
monkfish monkfish is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 106
Thanks: 9
Thanked 15 Times in 14 Posts
Default

http://bit.ly/11aDO4q

Quote:
mydomain.com - used for mail.mydomain.com and mydomain.com:8080
Did you buy a wildcard SSL certificate; ie *.mydomain.com as the world of SSL says the above two are different realms. Makes a difference as even if its SSL enabled your browser may still throw a warning as the site won't match the certificate. Worth checking.

These notes are specific to a/my Centos build. You will have to adapt as necessary.

- Sites > mydomain.com > web domain tab, enable SSL click save
- under SSL tab paste key and cert or paste bundle and save.
- wait for job to update config and look in /var/www/mydomain.com/ssl where you will see mydomain.com.crt and mydomain.com.key files
- copy your intermediate.crt file into same folder
- Go back to ispconfig control panel under sites > mydomain.com > options and in apache directives enter a line "SSLCertificateChainFile /var/www/mydomain.com/ssl/intermediate.crt" to match the filename you entered.
- Save and test

For ispconfig same principle but you may have to modify /etc/httpd/conf/sites-available/ispconfig.vhost yourself and enter SSLCertificateChainFile as a line in there manually. The ispconfig certs live in /usr/local/ispconfig/interface/ssl. Overwrite the .crt and .key files with yours and don't forget to copy the intermediate crt as well. Restart apache.

HTH

Last edited by monkfish; 1st June 2013 at 00:26.
Reply With Quote