View Single Post
  #14  
Old 23rd May 2013, 16:51
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 36,411
Thanks: 834
Thanked 5,496 Times in 4,326 Posts
Default

Hi,

roundcube connects to the local server on port 25, this is ok and not related to your problem. Please undo the changes in /etc/services, this change will only break the setup and will not help.

The problem is that your server cant be reached from the internet caused by your isp is blocking port 25, it is not a problem of the local server setup or local mail delivery.

As long as port 25 is closed, you wont be able to receive any mails on your system that were sent to you over the internet.

What your isp suggested to you are settings for running a mail client, not server, with this ISP.

To enable your server to send emails again, you have to use a realy server. Most likely your ISP provides one for its customers if they disallow other methods to send email. You should ask them for the hostname and smtp login details of that relay server and enter them in ispconfig under System > Server config > mail (Relayhost, Relay user, relay password).

For the email receiving I'am not aware of a solution to circumvent the blocked port except of using a server which is located in the internet. Instead of moving the IP to a new ISP, you might be able to change the dns record of your domain name to a new server / virtual server with new ip which is reachable on port 25.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote