View Single Post
  #3  
Old 22nd May 2013, 13:21
monkfish monkfish is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 106
Thanks: 9
Thanked 15 Times in 14 Posts
Default

http://www.howtoforge.com/forums/showthread.php?t=58408

May I respectfully suggest you've put far too little information in your post for anybody to even consider where your problem may lie.

However, thoughts are:-

- from your limited description sounds like form-to-email type page.

- Is it done in PHP? Do you have all required libraries installed? Does the site in question have permissions to run the script? Is suExec getting in the way?

- are you getting an error message when you access the page? Perhaps 500 internal server error? Have you tried turning php errors on to see if you get anything spat back at your browser?

- whats going on on your error logs - something like "tail -f /var/www/<domain>/log/error.log" and see if anything is logged when you access the page.

- same for suexec if you suspect issues - "tail -f /var/log/httpd/suexec.log" if you think thats causing the problems.

- if none of that shows anything, pay attention to your mail logs, eg. "tail -f /var/log/maillog" and watch what is happening there. Is the mail being generated but rejected by your mailer? Is it destined for local mailbox or an outside address? Can you otherwise send emails using that same box, eg roundcube logged into a local mailbox?

More generally, perhaps think about a "development" machine, eg vmware or similar where you have all the php debugging and error notices turned on and can monitor logs accordingly. Once script working on there would be easy to deploy it to real-world site.
Reply With Quote