View Single Post
  #1  
Old 19th May 2013, 13:32
gzx21 gzx21 is offline
Junior Member
 
Join Date: May 2013
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default Mailman not working in ISPConfig 3.0.5.2

Hello, I have a fresh installation of ISPConfig on Debian Wheezy 64bit. I closely followed this installation guide:

http://www.howtoforge.com/perfect-se...ot-ispconfig-3

Everything seems to work fine, however mailman seems to be not working. When I try to access
http://myserver.mydoman.com:8081/cgi-bin/mailman/admin/
I see welcome message as expected. However when I create list called 'dummy' (as a user) for mydomain (email address dummy@mydomain.com) I cannot access its web interface via
http://myserver.mydomain.com:8081/cg...an/admin/dummy

nginx log shows this:
2013/05/19 13:26:55 [error] 9265#0: *45 FastCGI sent in stderr: "Cannot chdir to script directory (/usr/lib/cgi-bin/mailman/admin)" while reading response header from upstream, client: 178.248.249.95, server: _, request: "GET /cgi-bin/mailman/admin/dummy HTTP/1.1", upstream: "fastcgi://unix:/var/run/fcgiwrap.socket:", host: "myserver.mydomain.com:8081"
(pastebin for better readability)


Is there anything I am missing?

Thanks in advance!

GZ

::EDIT::
By the way, should /var/www/apps be empty? I also noticed errors about missing pictures:
2013/05/19 13:54:11 [error] 9262#0: *117 open() "/var/www/apps/images/mailman/gnu-head-tiny.jpg" failed (2: No such file or directory), client: 178.248.249.95, server: _, request: "GET /images/mailman/gnu-head-tiny.jpg HTTP/1.1", host: "myserver.mydomain.com:8081", referrer: "http://myserver.mydomain.com:8081/cgi-bin/mailman/admin"

Last edited by gzx21; 19th May 2013 at 14:03. Reason: Additional information
Reply With Quote
Sponsored Links