View Single Post
  #3  
Old 11th May 2013, 11:50
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,265
Thanks: 80
Thanked 24 Times in 20 Posts
Default

This didn't give any errors apparently so I started it:

Quote:
apt-get install libc6/wheezy libc-dev-bin/wheezy libc6-dev/wheezy libc6-i686/wheezy gcc-4.4/wheezy gcc-4.4-base/wheezy cpp-4.4/wheezy libgcc1/wheezy libgomp1/wheezy libgmp10/wheezy libmpfr4/wheezy multiarch-support/wheezy initscripts/wheezy libstdc++6/wheezy util-linux/wheezy libblkid1/wheezy libslang2/wheezy libtinfo5/wheezy
BUT it still resulted in one:

Quote:
Preparing to replace libc6 2.11.3-4 (using .../libc6_2.13-38_i386.deb) ...
Checking for services that may need to be restarted...
Checking init scripts...
WARNING: this version of the GNU libc requires kernel version
2.6.26 or later. Please upgrade your kernel before installing
glibc.

The installation of a 2.6 kernel _could_ ask you to install a new libc
first, this is NOT a bug, and should *NOT* be reported. In that case,
please add lenny sources to your /etc/apt/sources.list and run:
apt-get install -t lenny linux-image-2.6
Then reboot into this new kernel, and proceed with your upgrade
dpkg: error processing /var/cache/apt/archives/libc6_2.13-38_i386.deb (--unpack):
subprocess new pre-installation script returned error exit status 1
configured to not write apport reports
Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.13-38_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
So it looks like I need to upgrade my kernel:
Quote:
uname -r
2.6.18-028stab094.3
Reply With Quote