View Single Post
  #2  
Old 11th May 2013, 11:34
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,258
Thanks: 76
Thanked 23 Times in 19 Posts
Default

making slowly progress:

- edited my sources list, put it all back to SQUEEZE then tried this:

Quote:
apt-get install libc6/squeeze libc-bin/squeeze perl/squeeze perl-modules/squeeze locales/squeeze -u
result:

Quote:
apt-get dist-upgrade -u
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.
THEN using this tutorial: http://www.howtoforge.com/how-to-upg...eeze-to-wheezy

I changes my sources to match WHEEZY then did an apt-get upgrade which resulted in:

Quote:
Errors were encountered while processing:
/var/cache/apt/archives/mysql-client-5.5_5.5.30+dfsg-1.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
did apt-get upgrade again and saw this:

Quote:
Unpacking replacement mysql-client-5.5 ...
dpkg: error processing /var/cache/apt/archives/mysql-client-5.5_5.5.30+dfsg-1.1_i386.deb (--unpack):
trying to overwrite '/usr/bin/mysql', which is also in package mysql-client-core-5.5 5.5.30-1~dotdeb.0
configured to not write apport reports
dpkg-deb: subprocess paste killed by signal (Broken pipe)
Errors were encountered while processing:
/var/cache/apt/archives/mysql-client-5.5_5.5.30+dfsg-1.1_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)
YES, I did use dotdeb at some stage so I removed mysql-client-core-5.5:

Quote:
apt-get remove mysql-client-core-5.5 -u
I followed up with an apt-get dist-upgrade and was told all is well but:

Quote:
The following packages will be REMOVED:
libdigest-sha1-perl php5-gd php5-suhosin
and
Quote:
164 upgraded, 66 newly installed, 3 to remove and 1 not upgraded.
after going through with this, I hit an error which I missed copy/pasting saying something about some libc library needing a 2.6 kernel and I am supposed to add some "LENNY" sources to my sources list but Lenny is way outdated, WTF?

so currently I'm back to this:

Quote:
apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
ifupdown : Depends: initscripts (>= 2.88dsf-25) but 2.88dsf-13.1+squeeze1 is installed
libc6 : Depends: libc-bin (= 2.11.3-4) but 2.13-38 is installed
locales : Depends: glibc-2.13-1
E: Unmet dependencies. Try using -f.
and then I tried this which brings me back to my original libc6 problem so I guess I'll just have ot go all the way back to squeeze !?

Quote:
apt-get install initscripts/wheezy util-linux/wheezy -u
Reading package lists... Done
Building dependency tree
Reading state information... Done
Selected version '2.88dsf-41' (Debian:7.0.0/stable [i386]) for 'initscripts'
Selected version '2.20.1-5.3' (Debian:7.0.0/stable [i386]) for 'util-linux'
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libc6 : Depends: libc-bin (= 2.11.3-4) but 2.13-38 is to be installed
locales : Depends: glibc-2.13-1
util-linux : PreDepends: libblkid1 (>= 2.20.1) but 2.17.2-9 is to be installed
PreDepends: libslang2 (>= 2.2.4) but 2.2.2-4 is to be installed
PreDepends: libtinfo5 but it is not going to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Reply With Quote