View Single Post
  #1  
Old 11th May 2013, 11:45
Ovidiu Ovidiu is offline
Senior Member
 
Join Date: Sep 2005
Posts: 1,269
Thanks: 84
Thanked 25 Times in 21 Posts
Default stuck in upgrade hell

Tried to upgrade from Debian squeeze to wheezy and am stuck. Read and tried following a couple of tutorials including the one available here on howtoforge.

Currently getting this:

Quote:
apt-get dist-upgrade -u -s
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these.
The following packages have unmet dependencies:
libc6 : Depends: libc-bin (= 2.11.3-4) but 2.13-38 is installed
locales : Depends: glibc-2.13-1 but it is not installable
perl-modules : Depends: perl (>= 5.14.2-1) but 5.10.1-17squeeze6 is installed
E: Unmet dependencies. Try using -f.
using apt-get -f install suggests:

0 upgraded, 0 newly installed, 289 to remove and 0 not upgraded.
5 not fully installed or removed.
After this operation, 461 MB disk space will be freed.


So I did not go forward with that.

Any hints? Google only gives me 2 viable results and both have no real solution.
Reply With Quote
Sponsored Links