View Single Post
  #30  
Old 5th May 2013, 15:26
Hans Hans is offline
Moderator
 
Join Date: Dec 2005
Location: Montfoort, The Netherlands
Posts: 2,256
Thanks: 213
Thanked 648 Times in 294 Posts
Exclamation Error after upgrade ISPConfig version 3.0.4.6 to the latest version 3.5.0.2.

I got a problem after upgrading from ISPConfig version 3.0.4.6 to the latest version 3.5.0.2 on Debian 6.

All websites are up and running, but the ISPConfig cp itself is unavailable.
I got the following errors when ik browse to the cp logon web page:

Warning: require_once(/usr/local/ispconfig/interface/lib/config.inc.php) [function.require-once]: failed to open stream: Permission denied in /usr/local/ispconfig/interface/web/index.php on line 31

Fatal error: require_once() [function.require]: Failed opening required '../lib/config.inc.php' (include_path='.:/usr/share/php:/usr/share/pear') in /usr/local/ispconfig/interface/web/index.php on line 31

What could could be the reason that the ISPConfig cp is not available?
There is probably an open_basedir restriction in effect, but where can this be solved, so that ispconfig3 will be available again.

***EDIT***
in the mean time i solved the problem by doing:
chmod 660 /usr/local/ispconfig/interface/lib/config.inc.php
__________________
Hans

MrHostman | Master in managed hosting

Last edited by Hans; 5th May 2013 at 16:50.
Reply With Quote