View Single Post
  #1  
Old 3rd May 2013, 14:55
darkmysterious darkmysterious is offline
Junior Member
 
Join Date: May 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Unhappy smstools problem[cant send sms]

hi guyz,

i've installed smstplay and sms server tools using the below link

http://www.howtoforge.com/installati...-debian-server

everything is working fine during installation,but when i tried to send sms using my samsung galaxy s1 all messages remains in queue

any help please,i spent so much time trying to let that server send with no use

my configuration as the below

device conguration

Quote:
# configuration
devices = modem1
loglevel = 4
logfile = /var/log/sms/smstools.log
outgoing = /var/spool/sms/outgoing
checked = /var/spool/sms/checked
failed = /var/spool/sms/failed
incoming = /var/spool/sms/incoming
sent = /var/spool/sms/sent
delaytime = 6
errorsleeptime = 12
blocktime = 180
autosplit = 3
receive_before_send = yes
# Modem configuration # iTegno 3000 USB
[modem1]
#init =
incoming = yes
report_device_details = yes
report = yes
#pin = baudrate = 115200
init1 = AT+CNMI=1,0,0,2,0
#nit2 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
device = /dev/ttyACM1

and my log file as below

Quote:
2013-05-03 15:49:35,2, smsd: Smsd v3.1.15 started.
2013-05-03 15:49:35,2, smsd: Running as root:root.
2013-05-03 15:49:35,4, smsd: File mode creation mask: 022 (0644, rw-r--r--).
2013-05-03 15:49:41,7, modem1: ## Start of device details
2013-05-03 15:49:41,7, modem1: # Manufacturer identification:
2013-05-03 15:49:41,7, modem1: -> AT+CGMI
2013-05-03 15:49:42,7, modem1: <- SAMSUNG
OK
2013-05-03 15:49:42,7, modem1: # Model identification:
2013-05-03 15:49:42,7, modem1: -> AT+CGMM
2013-05-03 15:49:42,7, modem1: <- AT+CGMMGT-I9003
OK
2013-05-03 15:49:42,7, modem1: # Revision identification:
2013-05-03 15:49:42,7, modem1: -> AT+CGMR
2013-05-03 15:49:43,7, modem1: <- I9003JXKP3
OK
2013-05-03 15:49:43,7, modem1: # New message indications, list of supported modes:
2013-05-03 15:49:43,7, modem1: -> AT+CNMI=?
2013-05-03 15:49:43,7, modem1: <- +CNMI: (0-2),(0-3),(0-3),(0-2),(0,1)
OK
2013-05-03 15:49:43,7, modem1: # New message indications, current settings:
2013-05-03 15:49:43,7, modem1: -> AT+CNMI?
2013-05-03 15:49:44,7, modem1: <- +CNMI: 1,0,0,2,0
OK
2013-05-03 15:49:44,7, modem1: # Preferred message storage, list of supported mem's:
2013-05-03 15:49:44,7, modem1: -> AT+CPMS=?
2013-05-03 15:49:44,7, modem1: <- +CPMS: ("BM","ME","SM","SR"),("ME","SM"),("BM","ME","SM", "SR")
OK
2013-05-03 15:49:44,7, modem1: # Phonebook storage, available mem's:
2013-05-03 15:49:44,7, modem1: -> AT+CPBS=?
2013-05-03 15:49:45,7, modem1: <- OK
2013-05-03 15:49:45,7, modem1: # List messages, list of supported stat's:
2013-05-03 15:49:45,7, modem1: -> AT+CMGL=?
2013-05-03 15:49:45,7, modem1: <- +CMGL: (0-4)
OK
2013-05-03 15:49:45,7, modem1: # Delete message, list of supported values:
2013-05-03 15:49:45,7, modem1: -> AT+CMGD=?
2013-05-03 15:49:46,7, modem1: <- +CMGD: ( ),( 0, 1, 2, 3, 4 )
OK
2013-05-03 15:49:46,7, modem1: # Phone activity status, list of supported stat's:
2013-05-03 15:49:46,7, modem1: -> AT+CPAS=?
2013-05-03 15:49:47,7, modem1: <- +CPAS: (0-5)
OK
2013-05-03 15:49:47,7, modem1: # TE character set, list of supported charset's:
2013-05-03 15:49:47,7, modem1: -> AT+CSCS=?
2013-05-03 15:49:47,7, modem1: <- +CSCS: ("UCS2", "IRA", "HEX", "GSM")
OK
2013-05-03 15:49:47,7, modem1: # TE character set, current setting:
2013-05-03 15:49:47,7, modem1: -> AT+CSCS?
2013-05-03 15:49:48,7, modem1: <- +CSCS: "IRA"
OK
2013-05-03 15:49:48,7, modem1: ## End of device details
and my dmesge like the below


Quote:
[ 1520.057028] usb 1-5: new high speed USB device using ehci_hcd and address 22
[ 1520.189406] usb 1-5: New USB device found, idVendor=04e8, idProduct=685e
[ 1520.189410] usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 1520.189412] usb 1-5: Product: SAMSUNG_Android
[ 1520.189414] usb 1-5: Manufacturer: SAMSUNG
[ 1520.189416] usb 1-5: SerialNumber: 6AE20002FFFC0000
[ 1520.189512] usb 1-5: configuration #1 chosen from 1 choice
[ 1520.190270] scsi14 : SCSI emulation for USB Mass Storage devices
[ 1520.190347] usb-storage: device found at 22
[ 1520.190348] usb-storage: waiting for device to settle before scanning
[ 1520.190561] cdc_acm 1-5:1.1: This device cannot do calls on its own. It is not a modem.
[ 1520.190626] cdc_acm 1-5:1.1: ttyACM0: USB ACM device
[ 1525.189219] usb-storage: device scan complete
[ 1525.190185] scsi 14:0:0:0: Direct-Access Texas In struments Inc.OM AP4 PQ: 0 ANSI: 2
[ 1525.190556] scsi 14:0:0:1: Direct-Access Texas In struments Inc.OM AP4 PQ: 0 ANSI: 2
[ 1525.190945] sd 14:0:0:0: Attached scsi generic sg2 type 0
[ 1525.191109] sd 14:0:0:1: Attached scsi generic sg3 type 0
[ 1525.194922] sd 14:0:0:0: [sdb] Attached SCSI removable disk
[ 1525.195538] sd 14:0:0:1: [sdc] Attached SCSI removable disk
[ 3828.710623] usb 1-5: USB disconnect, address 22
[ 5198.360041] usb 1-5: new high speed USB device using ehci_hcd and address 23
[ 5198.493008] usb 1-5: New USB device found, idVendor=04e8, idProduct=685e
[ 5198.493012] usb 1-5: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[ 5198.493015] usb 1-5: Product: SAMSUNG_Android
[ 5198.493017] usb 1-5: Manufacturer: SAMSUNG
[ 5198.493019] usb 1-5: SerialNumber: 6AE20002FFFC0000
[ 5198.493119] usb 1-5: configuration #1 chosen from 1 choice
[ 5198.493856] scsi15 : SCSI emulation for USB Mass Storage devices
[ 5198.493956] usb-storage: device found at 23
[ 5198.493958] usb-storage: waiting for device to settle before scanning
[ 5198.494159] cdc_acm 1-5:1.1: This device cannot do calls on its own. It is not a modem.
[ 5198.494221] cdc_acm 1-5:1.1: ttyACM1: USB ACM device
[ 5203.493554] usb-storage: device scan complete
[ 5203.494154] scsi 15:0:0:0: Direct-Access Texas In struments Inc.OM AP4 PQ: 0 ANSI: 2
[ 5203.494654] scsi 15:0:0:1: Direct-Access Texas In struments Inc.OM AP4 PQ: 0 ANSI: 2
[ 5203.495334] sd 15:0:0:0: Attached scsi generic sg2 type 0
[ 5203.495759] sd 15:0:0:1: Attached scsi generic sg3 type 0
[ 5203.500886] sd 15:0:0:0: [sdb] Attached SCSI removable disk
[ 5203.501523] sd 15:0:0:1: [sdc] Attached SCSI removable disk
note that when im tyring to send message there is no log that shows if there is any error or not
also note that i can send sms using "sendsms" command line

thank you

Last edited by darkmysterious; 4th May 2013 at 15:13.
Reply With Quote
Sponsored Links