View Single Post
Old 3rd May 2013, 08:48
till till is offline
Super Moderator
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 37,001
Thanks: 840
Thanked 5,650 Times in 4,460 Posts

What is happening is when you connect to a website that wasn't configured to use ssl, but try to connect via https://, it connects to the first vhost that is configured to use ssl.
Thats ok and the default behaviour of webservers. If a vhost is requested that does not exist, the first vhost on the saem IP is shown.

May be this is by design, but I would like it more to get no connection at all (or maybe a page saying there is no website on this url).
Would something like this be posiible?
Add a default vhost which has ssl enabled by ading a site with the domain "000default.tld".It does not matter that the domain exists, it just ahs to be the first in alphabetical order on your servers. Or you ensure that ssl websites do not share the IP address with other sites.
Till Brehm
Get ISPConfig support and the ISPConfig 3 manual from
Reply With Quote