View Single Post
  #1  
Old 30th April 2013, 11:44
snowfly snowfly is offline
Member
 
Join Date: Jul 2006
Posts: 91
Thanks: 0
Thanked 4 Times in 3 Posts
Default Enabling SSL for site does nothing

Currently using ISPConfig 3.0.5.2 in a multi-server setup.
Recently added a new web server to the multi setup, created a website on this server (only site on server), enabled the SSL option, went to SSL page, selected Country & SSL domain, Pasted the SSL Certificate & Bundle (from an external SSL provider), set SSL Action = Save Certificate

Waited a minute for job to be processed.
Checked site config at /etc/apache/site-available/mydomain.xyz
Only has a <VirtualHost *:80> section.
No <VirtualHost *:443> section

I've setup SSL in past perfectly fine on other servers in our multi-server setup.

But the SSL checkbox option on this site, on this new server, does nothing.
Tried unticking SSL, saving site, waiting 2 minutes, re-ticking SSL, saving sites, waiting 2 minutes, but still no 443 VirtualHost section.

Any ideas?

I don't want to manually add the Virtualhost 443 section to the apache site conf file, as not doubt it will get overwritten by ISPConfig whenever a site change is made.
Reply With Quote
Sponsored Links