View Single Post
  #1  
Old 28th April 2013, 05:17
ganewbie ganewbie is offline
HowtoForge Supporter
 
Join Date: Apr 2013
Posts: 15
Thanks: 4
Thanked 0 Times in 0 Posts
Default http vs https question

Thanks for the great support,
I have installed ssl for the server and for the first site and things seems to be in order.

However, I have couple of questions:
1- when I try to login to the panel with https://mydomain.tld:8080 it works ;-) , but when i enter http://mydomain.tld:8080 I get to see html error code such as

<!DOCTYPE HTML PUBLIC "-//IETF//DTD HTML 2.0//EN">
<html><head>
<title>400 Bad Request</title>
</head><body>
<h1>Bad Request</h1>
<p>Your browser sent a request that this server could not understand.<br />
Reason: You're speaking plain HTTP to an SSL-enabled server port.<br />
Instead use the HTTPS scheme to access this URL, please.<br />
<blockquote>Hint: <a href="https://server.mydomain.tld:8080/"><b>https://server.mydomain.tld:8080/</b></a></blockquote></p>
</body></html>

Is there a way to redirect the address to the (https) to avoid showing some detail that I would prefer not show? and it make it look more professional?

2- My first site works in both http and https, how do I make it to redirect the to the https even if I type in the address bar http only?

3- What is the range of ports that I could use to change the default instead of 8080?

Thanks in advance,

George

Last edited by ganewbie; 28th April 2013 at 05:27. Reason: add more questions
Reply With Quote
Sponsored Links