View Single Post
Old 27th April 2013, 09:41
keithH keithH is offline
Junior Member
Join Date: Sep 2010
Posts: 12
Thanks: 0
Thanked 2 Times in 2 Posts
Default Possible ISPConfig Configuration Apache mistake with latest stable on Ubuntu 12.04LTS

Hi, folks:
I'm actually not reporting anything super serious, but hear it goes anyways.
When I got done using the tutorial found here: I found one interesting thing after finally completeing the installation.
I discovered that Apache2 was giving me warnings (and a hole lot of them) about nameVirtualHost *:80 and NameVirtualHost *:443 having no virtual hosts, (about three of four times printing to the screen.)
So I thought: This cannot do.
So I started looking about.
First instance?
Found a NameVirtualHost *:80 line.
Erased it, and saved the file.
The second?
Interestingly enough, occurred in the 000-ispconfig.conf file just after the alias lines.
NameVirtualHost *:80 and NameVirtualHost *443 respectively.
I removed those lines, using a nifty trick:
 sed -I '/NameVirtualHost /,/*:80/d' /etc/apache2/sites-enabled/000-ispconfig.conf
Then I ran the same, but for 443.
Once I erased those lines, and restarted Apache, all warnings whent away entirely.
I do not curiously, remember this ever occurring in ISPConfig, just in the latest stable builds.
Does anybody know why those directives are in the default ispconfig.conf vhost file for Apache2?
Doing this has not busted ISPConfig3 in any way, btw.
I would, like an explanation as to why those lines exist at all, if possible.
I don't like receiving warnigns all over the screen from Apache, personally. So I've delbt with it, at least for now.
When the next stable release comes up, after updating ISPConfig (unless I'm instructed not to in a reply post), I'll probably repeat the said code again just in case those lines hsow back up.
An explanation for those lines would be appreciated.
Did you developers do that on accident spessifying a Vhost line or two Apache would warn about?
I would suspect so.
Please clarify.

Last edited by keithH; 27th April 2013 at 09:46.
Reply With Quote
Sponsored Links