View Single Post
  #1  
Old 25th April 2013, 19:12
ronee ronee is offline
HowtoForge Supporter
 
Join Date: Oct 2006
Posts: 33
Thanks: 0
Thanked 2 Times in 2 Posts
Default /etc/group damaged

Hello,

This has been discussed extensively however have not found an answer that addresses our specific issue.

We have an ispconfig 2 server that has been running for years without issue and that we have not yet had time to migrate to ispconfig 3. This morning users were reporting issues receiving email and we found a wide variety of system problems stemming from the /etc/group file being mostly empty. We found one line in it only listing one group and that's it.

This caused numerous issues with apache, postfix, etc. To get things basically functioning, we copied the system portions of /etc/group from a similar server and that helped quite a bit, we were able to restart apache and postfix successfully.

We have tried a variety of solutions mentioned in other threads, such as observing the ispconfig.log for issues, making minor changes in all the sites on that server in hopes that the /etc/group will be properly written back out, as well as running this query on the ispconfig database and then modifying users:

update isp_isp_user SET status = 'u' where status = '';

We have managed to get some users back up and running by manually adding them back to their respective group entry (many are still missing) and then re-saving their user properties including their password.

But we have not yet found the underlying cause of the problem and it seems that our manual changes in /etc/group are being overwritten by ispconfig.

Any rapid input would be greatly appreciated.
Reply With Quote
Sponsored Links