View Single Post
  #3  
Old 20th April 2013, 20:27
darinpeterson darinpeterson is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Posts: 154
Thanks: 35
Thanked 13 Times in 13 Posts
Default

Thank you for taking the time to reply. I appreciate it.

Quote:
Originally Posted by falko View Post
You can change this behaviour under System > Server Configuration > Web > Permissions.
I have updated the immutable bit setting.

Quote:
Originally Posted by falko View Post
This is difficult and maybe only possible with mod_php because it runs as the Apache user (whereas FastCGI, CGI, etc. run as the web user), but I would advise against using this on a shared server because of security reasons.
I'm not familiar with mod_php, so I'm going to need to do some research on that.

I own the hardware node, and have setup a virtual server just for pb clients. None of them have ftp access to the server, they can currently only modify their websites through the pb interface.

I was hoping that I might be able to enable permissions by:

System > CP Users > pb > Groups

and checking each of the other user's.

If there's not a good way to do this, maybe I should setup this virtual node w/o ISPConfig, and configure Apache manually. I'd prefer to manage all with ISPConfig 3, but if it cannot be done without big architectural changes to pb, I will have to look at alternatives.

I have promised clients to have the migration completed this week. Once I have permissions issues resolved, it will probably take one day to perform all of the migrations.

What do you recommend?

Thank you,
Darin

Last edited by darinpeterson; 20th April 2013 at 20:28. Reason: clarify
Reply With Quote