View Single Post
  #9  
Old 20th April 2013, 18:53
markc markc is offline
Member
 
Join Date: Dec 2012
Posts: 56
Thanks: 6
Thanked 9 Times in 9 Posts
Default

As for the NIS lookup warning, the goog found this...

It's a warning, not an error. You eliminate it by removing NIS lookups.

First, find out what setting is using NIS:

$ postconf | grep nis:

This outputs something like

alias_maps = hash:/etc/aliases nis:mail.aliases

or

alias_maps = hash:/etc/mail/aliases nis:mail.aliases

Then, disable NIS lookups (as root):

# postconf -e alias_maps=hash:/etc/aliases

or

# postconf -e alias_maps=hash:/etc/mail/aliases

The exact command depends on "postconf | grep nis:" output.

Wietse

***

And here is another comment that explains why a bit better...

First of I didn’t ask postfix to do NIS lookups. These warning messages started showing up when I commented out alias_maps and decided to only use alias_database instead. The fix was simple.

alias_maps when commented, uses the default settings:
alias_maps = hash:/etc/aliases, nis:mail.aliases

This allows postfix to work even without explicit alias_maps settings. However the default also encumbers it with checking nis. Setting alias_maps explicitly eliminates the problem:

alias_maps = hash:/etc/aliases

Last edited by markc; 20th April 2013 at 18:58.
Reply With Quote