View Single Post
  #1  
Old 20th April 2013, 17:05
danhansen@denmark danhansen@denmark is offline
Senior Member
 
Join Date: Mar 2013
Posts: 249
Thanks: 53
Thanked 4 Times in 4 Posts
Exclamation ISPconfig 3 - Postfix - warning: dict_nis_init: NIS domain name not set - NIS lookups

Hi,

Anybody who can confirm this fix - please remember, its an ISPconfig Server:

Problem:
warning: dict_nis_init: NIS domain name not set - NIS lookups disabled

Solution maybe?:
Nov 21 10:21:13 web postfix/smtpd[30732]: warning: dict_nis_init: NIS
domain name not set - NIS lookups disabled


It's a warning, not an error. You eliminate it by removing
NIS lookups.
First, find out what setting is using NIS:

$ postconf | grep nis:

This outputs something like
alias_maps = hash:/etc/aliases nis:mail.aliases
or
alias_maps = hash:/etc/mail/aliases nis:mail.aliases

Then, disable NIS lookups (as root):

# postconf -e alias_maps=hash:/etc/aliases
or
# postconf -e alias_maps=hash:/etc/mail/aliases

The exact command depends on "postconf | grep nis:" output



Looking forward to hear from anyone
__________________
Kind Regards
Dan

__________________________________________________ _______
Fixed IP/WAN
DMZ -> "ispserverip"
Primary NameServer -> ns1.myprimarynameserver.tld
Secondary NameServer -> ns2.somedomainservice.tld

Ubuntu Server 12.04.4
ISPconfig 3 v.3.0.5.2 (Single Server Setup)
NameServer: BIND v.9.8.1-P1
SquirrelMail: v.1.4.22
MailServer: PostFix v.2.9.6 - IMAP/POP3 Dovecot v.2.0.19
Database: MySQL Server v.5.5.29-0ubuntu0.12.04.2
Tutorial: "ThePerfectServer-ISPconfig3-Ubuntu12.04"
Reply With Quote
Sponsored Links