View Single Post
  #5  
Old 12th April 2013, 21:52
maumar maumar is offline
Senior Member
 
Join Date: May 2009
Location: San Costanzo (PU - Italy)
Posts: 136
Thanks: 8
Thanked 11 Times in 11 Posts
Send a message via MSN to maumar Send a message via Skype™ to maumar
Default

Hello Falko
thnx for answer
Now, I have created a new web site on that server (debian7 + nginx +php-fpm).
I have selected php-fpm
In vhost file there No relatied to php and php-fpm

Code:
server {
        listen *:80;


        server_name 46ikymhds.it www.46ikymhds.it;

        root   /var/www/46ikymhds.it/web;



        location / {
                try_files $uri $uri/ /index.php?$args;
        }

       # Add trailing slash to */wp-admin requests.
       rewrite /wp-admin$ $scheme://$host$uri/ permanent;

        location ~* \.(jpg|jpeg|png|gif|css|js|ico)$ {
                expires max;
                log_not_found off;
        }


       include /var/www/46ikymhds.it/web/nginx.conf;

        location ~ /nginx.conf {
                        deny all;
                        access_log off;
                        log_not_found off;
        }




        index index.html index.htm index.php index.cgi index.pl index.xhtml;



        error_page 400 /error/400.html;
        error_page 401 /error/401.html;
        error_page 403 /error/403.html;
        error_page 404 /error/404.html;
        error_page 405 /error/405.html;
        error_page 500 /error/500.html;
        error_page 502 /error/502.html;
        error_page 503 /error/503.html;
        recursive_error_pages on;
        location = /error/400.html {
            internal;
        }
        location = /error/401.html {
            internal;
        }
        location = /error/403.html {
            internal;
        }
        location = /error/404.html {
            internal;
        }
        location = /error/405.html {
            internal;
        }
        location = /error/500.html {
            internal;
        }
        location = /error/502.html {
            internal;
        }
        location = /error/503.html {
            internal;
        }

        error_log /var/log/ispconfig/httpd/46ikymhds.it/error.log;
        access_log /var/log/ispconfig/httpd/46ikymhds.it/access.log combined;

        ## Disable .htaccess and other hidden files
        location ~ /\. {
            deny all;
            access_log off;
            log_not_found off;
        }

        location = /favicon.ico {
            log_not_found off;
            access_log off;
        }

        location = /robots.txt {
            allow all;
            log_not_found off;
            access_log off;
        }

        location /stats {
            index index.html index.php;
            auth_basic "Members Only";
            auth_basic_user_file /var/www/clients/client21/web1506/web/stats/.htpasswd_stats;
        }

        location ^~ /awstats-icon {
            alias /usr/share/awstats/icon;
        }

        location ~ \.php$ {
            deny all;
        }



}
it is like we haven't enabled php, as you can se by this piece:

Code:
        location ~ \.php$ {
            deny all;
        }


do u think that upgrade has corrupted configuration server?

many thnx
Reply With Quote