View Single Post
  #24  
Old 9th April 2013, 15:59
danhansen@denmark danhansen@denmark is offline
Senior Member
 
Join Date: Mar 2013
Posts: 255
Thanks: 55
Thanked 4 Times in 4 Posts
Exclamation

So when you say "it works" I presume you mean you can surf to your control panel on your DMZ server from the outside world but you can't get to the same site directly from another machine on your internal LAN?
Exactly!

My "solution" of hardwiring IPs and domainnames on each internal workstation should not be needed and is just a workaround in some bizarre situation. The domain I point to my external IP is the same as when I ping it from the inside on my laptop so when I surf to mydomain.tld my browser goes to my router and that passes it back into my internal LAN on the DMZ so in other words it doesn't matter if I ping my domain from inside or outside of my router it will still go the server on my DMZ. The nginx listen directive for ports 80 and 443 listen to everything on that server which is 127.0.0.1 and 192.168.xx.xx. If I type 192.168.xx.xx into my browser I still get the same vhost that I see by going to mydomain.tld from outside or inside my router.


I have my ISOConfig CP listen to port 443 so if I go to https://mydomain.tld I get my CP from inside or outside my router. If I use https://192.168.xx.xx then I still get the CP. You should be able to do the same or similar to this.
From the outside I just use my https://myfixedipnumber:8080 - from the inside https://192.168.x.xx:8080 . Have you changed the port ISPconfig listens to then? I'm not sure about this, which is why I have posted a thread with a question regarding the use of the servername from the outside. The name we gave it during installation was server1.domain.tld and was set up as a hostname and in the ISPconfig APP you are also told to enter "server1.example.tld" This is why I am a little confused. Well, don't use any mor time trying to explain me this, you are many steps ahead of me I must read the 373 pages for the third time

Kind Regards,
Dan

Last edited by danhansen@denmark; 9th April 2013 at 16:02. Reason: Ups.... Wrong botton.. Closed it before I had finished writing...
Reply With Quote