View Single Post
  #19  
Old 8th April 2013, 18:57
danhansen@denmark danhansen@denmark is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 176
Thanks: 36
Thanked 3 Times in 3 Posts
Exclamation

Quote:
Originally Posted by markc View Post
Has your router got an option to configure and internal IP as a DMZ? Is so then that will let ALL traffic through to the internal server on your private LAN network. Your external port scan indicates that port 80 is open but that doesn't say whether that is port 80 on the router or the one forwarded to on the internal server.

When you configure the webserver, tell it to listen on the INTERNAL LAN IP and on your linux desktop add "192.168.xx.xx yourdomainname.tld" to /etc/hosts to force your browser to go directly to the webserver on the LAN IP.

Also, when testing your DNS, set all your TTL settings to 300 seconds so any changes propagate within about 5 to 10 minutes.

Hi markc
,
My major problem has been solved!
Qurious, look here: http://www.howtoforge.com/forums/sho...95500#poststop

Regarding the quote:
1. What did you mean by "Set your web server to listen to the internal LAN IP of the server." If it's not the local server ip number, please show me what you mean. Maybe I still need some configuring.
2. To go directly to domain, add "domain.tld 192.168.x.xx" to "/etc/hosts" on desktop.
This I have to do for all the domains I want to go directly to, right? Do I have to make both "domain.tld" and "www.domain.tld" to be able to reach both types?

Looking forward to hear from you.

Kind Regards,
Dan
Reply With Quote