View Single Post
  #1  
Old 7th April 2013, 01:28
danhansen@denmark danhansen@denmark is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 187
Thanks: 39
Thanked 4 Times in 4 Posts
Exclamation Own Primary Nameserver - ISPConfig 3 - Glue-record/which IP

-------------------------------------------------------------------------------------------------------------------------------
Internet WAN: Fixed IP
Modem/Router/Accesspoint LAN/DHCP/NAT*
Static IP 192.168.1.200
Portforwarding: --> TCP 20,21,22,25,53,80,110,143,443,993,995,3306,8080,80 81,10000
--> UDP 53,3306

Ubuntu Server 10.04 (eth0 192.168.1.200 Static IP)
ISPConfig 3 v.3.0.5.2
"Single Server Setup - DNS, WWW, Mail, SQL"
Own Primary Nameserver: ns1.mydomain.dk (will host own domain mydomain.dk)

Tutorial: "http://www.howtoforge.com/ispconfig_...domain_schlund"
-------------------------------------------------------------------------------------------------------------------------------

Hi,
I hope someone will help me with this major issue:

Question:

1. When having own primary nameserver and using ISPConfig 3 - and forllowing this tutorial, which IP-number is it for the glue-record "ns1"? Is it the fixed IP/public IP or is it the local IP number for the server? (192.168.1.200) In the tutorial the example used is a public IP-number.

2. My Primary Nameserver is of course "approved" by the "Danish Top Level Domain Provider" DK-Hostmaster.dk and in the settings for the Nameserver there is a Glue-record pointing to "myfixedipnumber"(WAN) - But according to the tutorial the Glue-record is created in the Nameserver (text from tutorial):

"... Because ns1.hits4all.de will host the DNS records of its own domain, hits4all.de, we will have to create a glue record to avoid the hen <-> egg problem.
..."

So which one is the right one? Or is both needed?

The reason to these questions is, that I am having some real problems getting my ISPconfig to work. I have been working day and night for a week now. Today I read the 373 pages ISPconfig 3 Manual from beginning to end - this gave me a list of things to try and to ask you guys
If anyone should be interested in looking into this - please visit these other threads too:

[Websites works locally but not from the outside! I call upon the Experts to do magic]
http://www.howtoforge.com/forums/showthread.php?t=61301

[DNS - public or local ip-numbers]
http://www.howtoforge.com/forums/sho...385#post295385

[/etc/resolv.conf - ISPconfig 3 manual]
http://www.howtoforge.com/forums/showthread.php?t=61180


Looking forward to any kind of response

Kind Regards,
Dan
Reply With Quote
Sponsored Links