View Single Post
  #8  
Old 6th April 2013, 03:18
tek tek is offline
Junior Member
 
Join Date: Feb 2012
Location: Silicon Valley
Posts: 9
Thanks: 1
Thanked 0 Times in 0 Posts
Send a message via ICQ to tek Send a message via AIM to tek Send a message via Yahoo to tek Send a message via Skype™ to tek
Default Answering this more for everyone else

You have obviously solved this but anyone running across this with a similar error may not understand whats up so this is for them.

the problem was the directive you were using in the config file.

you changed docroot into dochroot

Apache needs to know where its documents are to be stored or as they call it its Document Root or docroot for short.

In the actual apache.conf or httpd.conf for many rpm based system its usually pulled in by an Include statement that causes apache to parse all your virtual domains and modules that its supposed to load.

Back in your sites-enabled folder inside of /etc/apache/ the master sites config file is the 000-default and to use that for this example it has a directive called
DocumentRoot .... then it has a path statement.

In the config you quoted it has no docroot hence one part of your problem.
Apache needs to know where to find its documents then once it see's them and identifies the .php on the end it finds its handler type calling out the suphp.conf file but it has no docroot or homefolder declared so to speak.
Reply With Quote