View Single Post
  #3  
Old 4th April 2013, 21:36
darinpeterson darinpeterson is offline
HowtoForge Supporter
 
Join Date: Nov 2011
Posts: 154
Thanks: 35
Thanked 13 Times in 13 Posts
Default

Hi SamTzu,

Thank you for the reply.

Quote:
Originally Posted by SamTzu View Post
Only way is to enter the FQDN in the OpenVZ as the VM hostname or manually edit /etc/hostname file and to use chattr +i /etc/hostname.
I have already set the hostname for the OpenVZ containers as the FQDN, if this is what you're talking about:

Code:
vzctl set mail --hostname server1.example.com --save
However, this does not solve the problem with the requirement that the command "hostname" producing "server1.example.com".

Quote:
Originally Posted by SamTzu View Post
I recommend the first option.

Normally /etc/hostname should not contain FQDN only the host name but this can be problematic on OpenVZ containers and you might have to manually modify on Postfix config's etc. and add the FQDN later.
If it's not required by ISPConfig, I would rather not change anything that might cause other issues.

If the only reason Falko has asked that the hostname be the FQDN is the concern for a collision of names in ISPConfig, then that would be useful to know. If there are other implications, I would like to know.

If you have more feedback, please provide it.

Regards,
Darin
Reply With Quote