View Single Post
  #4  
Old 2nd April 2013, 01:20
breakaway breakaway is offline
Junior Member
 
Join Date: Jun 2007
Posts: 21
Thanks: 2
Thanked 2 Times in 1 Post
Exclamation

Hi,

I'm still trying to fix this -- can anyone lend a hand?

I have edited the

Code:
 location /phpmyadmin { }
directive in

Code:
/etc/nginx/sites-available/apps.vhost
and added

Code:
fastcgi_param HTTPS on;
and restarted nginx but it doesn't help!

I found there is already a line there that says

Code:
fastcgi_param HTTPS $https;
Where is the $HTTPS variable defined? I can't find it in that file. Also commenting out this particular variable-driven line and forcing it with fastcgi_param HTTPS on; doesn't seem to help either. Navigating to https://my.server.tld:8081/phpmyadmin gives me an error, whereas http://my.server.tld:8081/phpmyadmin works.

I have a feeling I'm editing the wrong file(s)!

Any help appreciated!

EDIT: I have found that I am able to access both phpMyAdmin AND SquirrelMail on http://site.server.tld:8081/phpmyadmin or http://site.server.tld:8081/squirrelmail REGARDLESS of wether the directives are present or not inside ISPConfig in Sites > Domains > Optoins > nginx Directives.

I thought without the directives there, that particular site shouldn't have phpMyAdmin or SquirrelMail? Is my understanding of that incorrect? The guide says the following:

Quote:
If you want to use a /webmail or /squirrelmail alias that you can use from your web sites, this is a bit more complicated than for Apache because nginx does not have global aliases (i.e., aliases that can be defined for all vhosts). Therefore you have to define these aliases for each vhost from which you want to access SquirrelMail.

To do this, paste the following into the nginx Directives field on the Options tab of the web site in ISPConfig:

Last edited by breakaway; 2nd April 2013 at 01:35.
Reply With Quote