View Single Post
  #20  
Old 1st April 2013, 09:00
JeffryL JeffryL is offline
Member
 
Join Date: Apr 2011
Posts: 35
Thanks: 9
Thanked 0 Times in 0 Posts
Default

I noticed that since the update to 3.0.5.2 and/or an upgrade of apache (same time more or less) the webmail isn't working anymore by using the procedure above.

In my case I've configured the sites with php-fpm and then the directives put in the apache roundcube file are not applied anymore. No matter what I put in this file (within the conf.d directory) the openbase restriction remains in effect.

Also putting the lines:
Code:
AddType application/x-httpd-php .php
php_flag magic_quotes_gpc Off
php_flag track_vars On
php_admin_flag allow_url_fopen Off
php_value include_path .:/usr/share/php:/usr/share/pear
php_admin_value upload_tmp_dir /var/lib/roundcube/temp
php_admin_value open_basedir /usr/share/php:/usr/lib/roundcube:/etc/roundcube:/usr/share/roundcube:/var/lib/roundcube:/var/log/roundcube
php_flag register_globals off
in either one of the snippets (php or apache) didn't change the open-base settings.

I also added the roundcube lines to the open-basedir settings under the general configuration (php-permissions - server config) but this had no effect either. The open-basedir remains the same...

Anyone experiencing the same difficulties?

Done so far: reconfiguring website, altering roundcube.conf, altering snippets, changing to mod-php, switching back to php-fpm, disable the https/ssl

Does work though when using port 8080... which you didn't recommend...

Last edited by JeffryL; 1st April 2013 at 10:31.
Reply With Quote