View Single Post
  #3  
Old 30th March 2013, 02:03
vinnymeyer vinnymeyer is offline
Junior Member
 
Join Date: Mar 2013
Location: Upstate NY, USA
Posts: 3
Thanks: 4
Thanked 0 Times in 0 Posts
Default

Yes, I did - Apache::Reload is no longer packaged with Perl - has to be downloaded from cpan and compiled. Found this while looking for an answer today:

http://www.gossamer-threads.com/list.../modperl/98870

I installed cpan, and got the source for Apache::Reload from there, but doesn't build without another missing piece:

Can't locate ModPerl/MM.pm in @INC (@INC contains: /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at Makefile.PL line 41.

getting ModPerl::MM from cpan and trying to build it yields:

Can't locate ExtUtils/Embed.pm in @INC (@INC contains: lib Apache-Test/lib /usr/local/lib64/perl5 /usr/local/share/perl5 /usr/lib64/perl5/vendor_perl /usr/share/perl5/vendor_perl /usr/lib64/perl5 /usr/share/perl5 .) at lib/Apache2/Build.pm line 27.

I know almost nothing about Perl and its environment, so I'm not comfortable digging any deeper to figure out what pieces to put together make the pieces to put together to build Apache2::Restart. If someone has a bit of a handle on this, as far as either getting it packaged so it can be installed with rpm, or suggesting the steps to build this so it can be added to the Perfect Server how-to, I would be very grateful.
Reply With Quote