View Single Post
  #1  
Old 25th March 2013, 13:32
vistree vistree is offline
Member
 
Join Date: Aug 2006
Posts: 57
Thanks: 2
Thanked 4 Times in 3 Posts
Default Does PHP 5.2 work as alternativ php-version?

Hi, I tried to setup php 5.2.17 on a ispconfig 3.0.5.1 with php 5.3 as default (debian squeeze).
I used this tutorial as reference:
http://www.howtoforge.com/building-p...debian-squeeze

During compinling I got a note, that --enable-intl is an unknown option.
The rest was fine.

Now, when I activate fast-cgi -> 5.2.17 for an old drupal site (which displays fine with 5.3 but brings php5.3 incomp. errors) the web renders an error 500.
Debugging is hard and the only hint I find is the following error (error.log):
Code:
[Mon Mar 25 13:04:28 2013] [warn] [client XX.XXX.XX.XXX] (104)Die Verbindung wurde vom Kommunikationspartner zurückgesetzt: mod_fcgid: error reading data from FastCGI server
[Mon Mar 25 13:04:28 2013] [error] [client XX.XXX.XX.XXX] Premature end of script headers: index.php
Is there anything special on php 5.2?
Reply With Quote
Sponsored Links