View Single Post
  #2  
Old 24th March 2013, 17:47
wck wck is offline
Junior Member
 
Join Date: Mar 2013
Posts: 2
Thanks: 0
Thanked 0 Times in 0 Posts
Default

Well... problem solved.

Most tutorials about this problem mention smtpd.conf (which didn't exist on my server...) but the authentication code is actually in /etc/dovecot/dovecot-sql.conf

In this file, the SQL query has an extra "AND disable%Ls = 'n'" compared to what's usually in smtpd.conf and I realized `disablesmtp` was set to 'y' for the account I was trying to use (in dbispconfig.mail_user).

So, two solutions :
- manually set `disablesmtp` to 'n'
or
- check "enable receiving" in the settings for this email mailbox (although I'm using it purely to send email, not receiving).

testsaslauthd still tells me "authentication failed"... but eh, it works.

Last edited by wck; 24th March 2013 at 17:51.
Reply With Quote