View Single Post
  #5  
Old 22nd March 2013, 20:06
danhansen@denmark danhansen@denmark is offline
HowtoForge Supporter
 
Join Date: Mar 2013
Posts: 215
Thanks: 44
Thanked 4 Times in 4 Posts
Post It works! This is the default web page for this server. NOT on the outside!?!

Hi Darin,

Thanks for your response. Now I get it! As a matter of fact I once had a certificate from Verisign (I think that was their name) to a little thing I made for windows back in the days
And, thanks for the link, I will read it carefully and do just that!

But, being nice and clever at the same time costs So will you please look at this too?

The webserver runs in the local network. Doing this: 192.168.1.200 results in this:
It works!
This is the default web page for this server.
The web server software is running but no content has been added, yet.


Doing this: 192.168.1.200/webmail results in this:
SquirrelMail version 1.4.22
By the SquirrelMail Project Team
SquirrelMail Login
Name:
Password:


So, it runs locally - but I just can't get it to work from the outside. I've posted another thread in here regarding this, but maybe it is badly written since I've heard nothing yet. I think that is the case.
Domain works on outside nameserver, nameserver has A-record --> mystaticip --> router/firewall --> portforwarding 21, 22, 25, 53, 80, 110 and 8080(ispconfig) --> myserverip. I can reach ISPConfig from the outside doing a https on port 8080 but I can't reach the websites, not even the default website that works locally as shown above!?! I tried every combination to reach the websites: mystaticip, mystaticip:80, mydomain mydomain:80 I just keep getting the router/admin part! Can't reach the SqirrelMail webmail from the outside either, tried mystaticip/webmail, mystaticip:8081(from sqirrelmail/faq) mystaticip:8081/webmail etc. etc. All with both http/https! To me, being the novice that I am, it looks like the "catching-the-domain-client/user-and-direct-to-website" directory/docs doesn't work. In the old days I had a company hosting websites etc. But back the we had a ip-number for each website, and therefor it was pretty easy to setup. Just point it in the right direction in the nameserver A-record. Now I can't figure out how it works, and therefore my troubleshooting sucks! My other rather bad thread is this:
http://www.howtoforge.com/forums/showthread.php?t=61081

In this thread I found 1 error which has been fix'ed but it didn't change anything:
http://www.howtoforge.com/forums/sho...523#post294523

I just don't understand how it works. The missing link I call it: "Joe types www.mydomain.tld" --> nameserver --> mystaticip --> router/firewall --> portforwards 80 --> myserverip [missing link] --> mydomain/client /var/www/clients/client3/web1/web/
Symlinks? Virtual-stuff?

I totally get it if nobody can fix this - I tried for days now
But I am looking so much forward to any kind of response after 2 hours and 21 minutes of trying to explain somthing I don't get!

Kind Regards,
DanHansen@Denmark
Reply With Quote