View Single Post
  #9  
Old 5th March 2013, 19:19
bradboy bradboy is offline
Junior Member
 
Join Date: Mar 2013
Posts: 6
Thanks: 1
Thanked 0 Times in 0 Posts
Default

I opened /usr/local/ispconfig/server/lib/config.inc.php on the problem ns2 to retrieve the username and password. I used the information as seen below from the file...

Code:
//** Database settings for the master DB. This setting is only used in multiserver setups
$conf['dbmaster_type']                  = 'mysql';
$conf['dbmaster_host']                  = 'ns1.46-10.com';
$conf['dbmaster_database']              = 'dbispconfig';
$conf['dbmaster_user']                  = 'ispcsrv2';
$conf['dbmaster_password']              = 'OBSCURED';
$conf['dbmaster_new_link']              = false;
$conf['dbmaster_client_flags']  = 0;
Back on ns1, I did the following:
Code:
bradboy@ns1:~$ mysql -u root -p
Enter password: 
Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 4773
Server version: 5.5.29-1 (Debian)

Copyright (c) 2000, 2012, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql> use mysql;
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A
mysql> UPDATE mysql.user SET Password=PASSWORD('OBSCURED') WHERE User='ispcsrv2';
Query OK, 2 rows affected (0.00 sec)
Rows matched: 3  Changed: 2  Warnings: 0

mysql> flush privileges;
Query OK, 0 rows affected (0.00 sec)

mysql> quit
Bye
bradboy@ns1:~$
Over to ns2, I got:
Code:
root@ns2:~# /usr/local/ispconfig/server/server.sh
Unable to load the server configuration from database.
Just to make sure the /etc/hosts wasn't causing the problem, I added:
x.x.x.x ns1.46-10.com
to the host file on ns2. Although the changes are supposed to take effect immediately, I rebooted anyway.

On ns1 I added
y.y.y.y ns2.46-10.com
Once ns2 came back up and I kicked all of the other users off, I rebooted ns1 as well.

I still have the same problem. Your idea of the password issue gave me an idea though. I wanted to know if the ispcsrv2 user had host access in sql. Here is the result:
Code:
mysql> use mysql
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
mysql> select host, user from user;
+---------------+------------------+
| host          | user             |
+---------------+------------------+
| %             | ispconfig        |
| %             | ispcsrv2         |
| %             | root             |
| 127.0.1.1     | ispcsrv2         |
| ::1           | root             |
| localhost     |                  |
| localhost     | debian-sys-maint |
| localhost     | root             |
| ns1           |                  |
| ns1           | root             |
| ns1.46-10.com | ispconfig        |
| ns2.46-10.com | ispcsrv2         |
+---------------+------------------+
13 rows in set (0.00 sec)

mysql>
Puzzled, I rebooted the thing again before it started filling up with users. When it came back, the web interface now reports ns2's OS info. ( Silly cache ) We are getting somewhere.

I took a look in ns2's /etc/bind... and find it filled with the pri.domain.tld zone files. I remember the BIND zonefiles directory and wanted to make sure that it's set correctly for ns2, and it is.

I added a 000test.tld using the add zone wizard. ns2's named.conf.local got re-written with only the new test entry I added, and it's zone file went into /etc/bind/zones as expected.

ALMOST THERE!!!!
Do I just need to let it sit for a while to play catchup with all the other zones, or do I need to somehow force a complete reload?
Reply With Quote