View Single Post
  #4  
Old 4th March 2013, 19:29
pawan pawan is offline
Senior Member
 
Join Date: Jul 2010
Posts: 210
Thanks: 42
Thanked 5 Times in 5 Posts
Default

Well I have kind of solved everything like
if I sent mail to outside recipient using thunder-bird or MS outlook the mail is not going through,
however if I am sending mail using roundcube, which also connects on port 25, the mail is going through even to outside recipient.(can't make out the logic for this)

in my master.cf my setting are like

Code:
smtp      inet  n       -       -       -       -       smtpd
#smtp      inet  n       -       -       -       1       postscreen
#smtpd     pass  -       -       -       -       -       smtpd
#dnsblog   unix  -       -       -       -       0       dnsblog
#tlsproxy  unix  -       -       -       -       0       tlsproxy
submission inet  n       -       -       -       -       smtpd
  -o syslog_name=postfix/submission
  -o smtpd_tls_security_level=encrypt
  -o smtpd_sasl_auth_enable=yes
  -o smtpd_recipient_restrictions=permit_sasl_authenticated,reject
and setting for my main.cf are like:
Code:
smtpd_recipient_restrictions = permit_mynetworks,reject_unauth_destination
Do I need any further changes, to work it so that on port 25 the mails cannot sent outside of my network.

Also enforce a authentication for local delivery as well.
Reply With Quote