View Single Post
  #7  
Old 26th February 2013, 14:16
till till is online now
Super Moderator
 
Join Date: Apr 2005
Location: Lüneburg, Germany
Posts: 34,647
Thanks: 794
Thanked 5,002 Times in 3,911 Posts
Default

We found the reason for the first issue with the path, it is a bug in ispconfig versions before 3.0.5 which inserted a wrong path, the problem was not visible till now as the ispconfig interface had a mod_php fall back which has been removed now for security reasons.

The second issue is most likely related to the first one, php-fcgi has a problem to connect to mysql.

Here the steps for a short fix:

Edit the file ispconfig vhost file:

Centos: /etc/httpd/conf/sites-enabled/000-ispconfig.vhost
Debian / Ubuntu: /etc/apache2/sites-enabled/000-ispconfig.vhsot

and change the lines:

Code:
#  <IfModule mod_php5.c>
#    DocumentRoot /usr/local/ispconfig/interface/web/
#    AddType application/x-httpd-php .php
#    <Directory /usr/local/ispconfig/interface/web>
#      # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
#      Options FollowSymLinks
#      AllowOverride None
#      Order allow,deny
#      Allow from all
#	  php_value magic_quotes_gpc        0
#    </Directory>
#  </IfModule>
to:

Code:
  <IfModule mod_php5.c>
    DocumentRoot /usr/local/ispconfig/interface/web/
    AddType application/x-httpd-php .php
    <Directory /usr/local/ispconfig/interface/web>
      # php_admin_value open_basedir "/usr/local/ispconfig/interface:/usr/share:/tmp"
      Options FollowSymLinks
      AllowOverride None
      Order allow,deny
      Allow from all
	  php_value magic_quotes_gpc        0
    </Directory>
  </IfModule>
Then run:

chmod 660 /usr/local/ispconfig/interface/lib/config.inc.php

and restart apache. Then try to login again.
__________________
Till Brehm
--
Get ISPConfig support and the ISPConfig 3 manual from ispconfig.org.
Reply With Quote