View Single Post
  #5  
Old 26th February 2013, 09:06
DiMoNd DiMoNd is offline
Junior Member
 
Join Date: Apr 2011
Posts: 6
Thanks: 2
Thanked 0 Times in 0 Posts
Default Permission, ssh problems

Hi.

I have just installed a debian server with ispconfig following this guide: "The Perfect Server - Debian Squeeze (Debian 6.0) With BIND & Courier [ISPConfig 3]" and everything works ok but two things..

i) When I log into ispconfig panel under a user account, I create and add a website I then get "Forbidden
You don't have permission to access /xxxxxxxxx.com on this server."

This happens with every single website I add on my server. The only way I can fix this is go into "/etc/apache2/sites-enabled/100-xxxxxxxxx.com.vhost" and change the "<Directory /var/www/xxxxxxxx.com>
AllowOverride None
Order Deny,Allow
Deny from all
</Directory>"

to "<Directory /var/www/xxxxxxxxx.com>
AllowOverride None
Order Deny,Allow
Allow from all
</Directory>"

Only then I can see the website.

ii) When I add a ssh user(on ispconfig) I want this user to NOT be able to go to "/etc/..." .


Thank you!
Reply With Quote