View Single Post
  #1  
Old 26th February 2013, 03:49
mroppolo mroppolo is offline
Junior Member
 
Join Date: Jan 2010
Posts: 22
Thanks: 2
Thanked 0 Times in 0 Posts
Default Difficulties switching to port 587 in Postfix

Hello all -

My ISP has started blocking port 25 and I am having difficulty adding port 587 to my postfix configuration. I have added the following:

1) TLS settings in /etc/postfix/main.cf
smtpd_tls_cert_file = /etc/postfix/smtpd.cert
smtpd_tls_key_file = /etc/postfix/smtpd.key
smtpd_use_tls = yes
smtpd_tls_session_cache_database = btree:${data_directory}/smtpd_scache
smtp_tls_session_cache_database = btree:${data_directory}/smtp_scache
smtp_tls_security_level = encrypt
smtp_tls_CAfile = /etc/ssl/certs/ca-certificates.crt
smtp_tls_session_cache_database = btree:/var/lib/postfix/smtpd_scache_tls
tls_random_source=dev:/dev/urandom
2) SASL settings in /etc/postfix/main.cf
smtp_sasl_auth_enable = yes
smtp_sasl_security_options = noanonymous
smtp_sasl_password_maps = hash:/etc/postfix/saslpasswd
smtp_always_send_ehlo = yes
broken_sasl_auth_clients = yes
smtpd_sasl_authenticated_header = yes
3) relayhost settings in /etc/postfix/main.cf
relayhost = [smtp.comcast.net]:587
4) /etc/postfix/saslpasswd
[smtp.comcast.net]:587 <MyUser>:<MyPasswd>
5) I hashed /etc/postfix/saslpasswd with the following command:
postmap /etc/postfix/saslpasswd
6) I then executed the following commands:
postfix reload
/etc/init.d/postfix restart
7) I opened port 587 on my router

8) I added port 587 to my ISPConfig3 firewall

I still cannot send or receive emails, but I'm seeing this in my mail log:
postfix/smtp[4210]: 341721120004: to=, relay=127.0.0.1[127.0.0.1]:10024, delay=1039, delays=1039/0.04/0.01/0, dsn=4.7.4, status=deferred (TLS is required, but was not offered by host 127.0.0.1[127.0.0.1])
Is anything in configuration incorrect ? Am I missing any steps ?

Thanks !
Reply With Quote
Sponsored Links